0

I am trying to set up a web form project in .Net with SDL Web 8.5 as we do in case of previous version of Tridion [2013/2011].

I found the link to connect to Broker db using the CIL.

Is there any way so that I can directly use the cd_storage_conf.xml to connect to broker db, with out using the discovery service?

Update: 1

I implemented the .Net web application for the legacy application. The web site is working fine for the static content, but when I am using the dynamic component presentation it is not rendering anything.

The web page contains the following dynamic CP links. enter image description here

But the web page is totally blank. When I checked the logs I found this. enter image description here

Do I need to any reference for this ??

** I have upgraded the Tridion 2011 to Sdl web 8.5 also when I am trying to access the content using CIL the contents are getting rendered

  • 1
    You can use CD in "legacy mode" (sometimes also called "in-process") which is the same architecture as 2013 - but then you lose the scalability aspects of using the web services, as well as the fact you'll need to have Tridion running on your instance. In any case (and any version of Tridion) connecting to the DB directly is not supported. – Nuno Linhares Jun 13 '17 at 15:47
2

Yes you can achieve that but it is not recommended. It is available mainly for backward compatibility purposes. If you would like to configure in that way, follow the sdl docs to show the publication targets in CME as like in Tridion 2013 SP1 and implement the legacy style .NET web app with cd_storage_conf.xml specified in the config folder under the webapp\bin,

  1. Showing the Publishing Management node
  2. "Installing the legacy API (in-process) Server Role for a .NET Web application"
  • I tried the above link and is working fine. But I got an issue with the dynamic component Presentation . I have updated the ticket. – Manas.p Jun 19 '17 at 16:22
  • Hi Manas, looking at your update, it seems you missed to copy the web.config file from the installation media. It is missing Tridion httpmodules and HttpHandlers and hence the issue. Compare your web.config with the one which is available with the Tridion installation media and add the missing httpmodules and httphandlers – Rajesh Jun 19 '17 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.