4

We've noticed that when publishing our site, we get a lot of Warning messages in the publish queue indicating that although the publish was theoretically successful, there were no items that actually got resolved and published. We've been through several possible causes, as follows:

  1. Republish Only - We have checked that this wasn't checked. The problem also when explicitly publishing a single page.
  2. Structure group set to Publishable=false - we opened up the Structure group proprties to check that the checkbox was checked.
  3. Missing mapping in topology manager - We've checked using the cmdlets, and also the Topology Manager fly-out in the GUI.
  4. Missing Business process type - we'd checked the publication properties to see that the BPT was configured.
  5. Custom resolver - we don't have one

It's perhaps also interesting to note that some other items in the same publication work fine and can be published correctly. For the items which produce this warning, we can also see in the "Show Items to Publish" dialog that nothing is resolved.

What can be going wrong here? Where should we look?

  • 1
    I'm guessing Web 8.5 since you mention the Topology manager GUI. The Warning state is the appropriate one when no items are resolved, so the main question here is "why nothing is resolved". Can it possibly be caused by items in workflow which haven't reached the appropriate approval level? – Atila Sos Jun 23 '17 at 17:58
10

I would add one more possible cause to the list

Also check (any of) it's grand-parent Structure group properties:

if it is set to Publishable=false.

Although it doesn't seem a logical place to look for, but I have seen this behavior before.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.