I have installed DXA 1.7 (.Net) on SDL Web 8.5. I have managed to setup a fully functional Staging Content Delivery Server including Session Preview. But I'm running into issues on the Live Content Delivery Server. If I browse to the DXA homepage I get the following error:

2017-06-23 14:40:51,693 [25] ERROR - Failed to execute query Sdl.Web.Delivery.Service.ServiceQueryException: Failed to execute query ---> Microsoft.OData.Client.DataServiceQueryException: An error occurred while processing this request. ---> Microsoft.OData.Client.DataServiceClientException: {"error":{"code":"9000","message":"java.lang.RuntimeException: Not possible to retrieve the dynamic configuration"}} at Microsoft.OData.Client.QueryResult.ExecuteQuery() at Microsoft.OData.Client.DataServiceRequest.Execute[TElement](DataServiceContext context, QueryComponents queryComponents)

enter image description here

Apart from this error which is also logged by the Content Service, no other error is logged. The same error is logged in the site.log from the DXA website

I have checked the following:

  1. Whether the Context service is accessible with Postman
  2. Whether the Topology is correct
  3. Whether the web capability element is present in the cd_storage_conf.xml of the cd_storage_conf.xml

Any ideas?




2 Answers 2


It appears that there were few problems with the linking of Base URL's in the discovery database which was causing this issue. It could not be identified why this inconsistencies in the DB, which should have been resolved by syncing (overwriting) from Topology side. After running the following queries the issue was resolved:

delete from CONFIGURATION_VALUE where ITEM_ID = '799a1e02-78e4-449d-
delete from CONFIGURATION_VALUE where ITEM_ID = 'efe93f0f-6f25-4997-
delete from CONFIGURATION_ITEM where ID = '799a1e02-78e4-449d-916f-
delete from CONFIGURATION_ITEM where ID = 'efe93f0f-6f25-4997-8891-

I have seen this error few times in our environment, but is very difficult to reproduce again. Restart your content micro service and recycle your dxa app pool.It will start to work again.

Update : Please check the following link to see if there is any difference in your discovery service Web Capability between Staging and Live environment setup, code:9000 error message in SDL Web8 environment

  • Hi Rajesh, thanks for your reply. I did flush the app pool. I even reinstalled the services. Are you sure you got the same error: "Not possible to retrieve the dynamic configuration"? Commented Jun 23, 2017 at 20:30
  • I think, it is the discovery service configuration for Live environment which is causing this issue(I have updated my answer and added a link which discuss about similar issue). Please cross check the discovery.svc address in your live DXA Website for right microservice address and has OAuth user credentials
    – Rajesh
    Commented Jun 24, 2017 at 8:42
  • I also found this link and I have double checked that the webcapability element is present in both the cd_storage_conf.xml and in the discovery database. I also double checked if the correct ttm-websites ids are registered in the discovery database. Is there a way to get more logging other than the Java runtime error? Commented Jun 24, 2017 at 11:03
  • 1
    @GertdeHeul did you try updating the discovery registration java -jar discovery-registration.jar update Commented Jun 29, 2017 at 14:17
  • @BartKoopman, yes both update and sync Commented Jun 29, 2017 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.