5

ExternalContentLibraryStubSchema-mm blueprint problem two different schema

 - DXA MediaManager Module installs it in 100 Master "Modules/MediaManager"

 - MediaManager installed it in 200 Example Content "Content/STUBS"

So there is a problem since the mm ecl content is based on the stubs-ExternalContentLibraryStubSchema-mm schema but we want it to be based on the DXA-ExternalContentLibraryStubSchema-mm.

So I tried to promote the stubs-ExternalContentLibraryStubSchema-mm to 100 Master so that we can update the DXA MediaManager Templates, but that is not allowed.

"Cannot promote or demote an external content library stub"

Is there an easy way to resolve this problem?

At the moment I don't like the options I can think of

  • Localise all of the DXA MediaManage DXA Templates in the 200 Publication

OR

  • Reinstall Media Manager at the 100 Master level
  • Why do you want to use the DXA MM Schema per se? I expect the other Schema to work too (if it has the same title). – Rick Pannekoek Jul 7 '17 at 14:27
  • The other schema does not work. Its a blueprint problem because the stubs-ExternalContentLibraryStubSchema-mm cannot be referenced in the 100 Master "Modules/MediaManager, Please explain what relevance the title of the schema has here. – Chris Mills Jul 7 '17 at 14:43
  • Right, I see. Indeed, it seems that Schema installed by MM is at the wrong location in your BluePrint. It is unfortunate that promoting it is not allowed :-( – Rick Pannekoek Jul 8 '17 at 14:54
  • Regarding relevance of the title: DXA uses the title of a MM Schema as semantic type name. As a result, MM Schemas with the same title with be interchangeable w.r.t. semantic mapping. – Rick Pannekoek Jul 8 '17 at 14:56
4

My goal was to move the Connector installation to the 100 Master level.

I tried deleting stubs and schema , editing the ExternalContentLibrary.xml stubs folder to point at 100 level to run the connector repair.

Repair failed so I had to go for the full re install.

  • Backup ExternalContentLibrary.xml and TridionSTS.xml as you settings will be lost.
  • Uninstall the connector
  • Delete all Stubs and ExternalContentLibraryStubSchema-mm
  • Promote STUBS folder to 100 Master level
  • Install the connector with new STUBS location
  • Edit ExternalContentLibrary.xml [ServiceEndPointAddress] and [ServiceCertificate]
  • Edit TridionSTS.xml [SigningCertificate] and [EncryptingCertificate]
  • Restart

Now when the connector installs it sees the DXA ExternalContentLibraryStubSchema-mm schema and everything is OK.

0

Check your ExternalContentLibrary.xml configuration file. It should be possible to reconfigure ECL to use the MM Schema that comes with DXA MM Module (note that that one also defines some additional metadata fields which can be used by the DXA MM Module).

I'm not sure if you already have actual ECL Stubs based on the other Schema? If so, you could switch them over to the DXA MM Schema using the Core Service API.

  • I did not find an element to reconfigure the MM Schema in the ExternalContentLibrary.xml and did not find an xsd for the ExternalContentLibrary either. Can you tell me where I can find the xsd? – Chris Mills Jul 11 '17 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.