When we click "Update Preview" on our site using XPM in IE, we always get the following javascript error: "Access is denied." in IE console and the browser never finishes the "Loading.." overlay.

The error comes from Content_v7.1.0.66.15_.aspx, Line: 38, Column: 312, which refers to var a=window.parent.frames["cookie_cleaner"].

In Chrome there is no issue. Any clues?

This can happen if you haven't added an se_blank.html file to your website. In IE it probably loaded an error page from a different domain then (when you have "friendly error messages" turned on) which leads to this access denied error when attempting to access it.

To fix the problem, you should follow the following installation instructions: Preventing 404 errors on your staging Web site

  • I placed se_blanck.html in the specified location, but still the issue persists. Also I am seeing lot of errors like SEC7111: HTTPS security is compromised by res://ieframe.dll/* – GVK Jul 10 '17 at 20:29
  • Make sure you spelled it correctly :) And check the logs of your staging website to see what status code is returned for the request for that file. – Peter Kjaer Jul 11 '17 at 14:28
  • :) That was typo in the comments. – GVK Jul 11 '17 at 17:48

Our issue got resolved. We had some internal URL Rewrites which was causing the issue. Corrected it and "Update Preview" started working in IE too.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.