I copy a line of text from a file. I then open up a component, select a rich text field and then use the Format > Paste button. Nothing is pasted. Nothing happens. I can paste fine using ctrl + v. Opening firebug doesn't show any errors.

The reason I need this is many users would like to use the Paste Special functionality but this doesn't work either.

I am running 2011 SP1 HR2.

Maybe I'm doing something wrong? Any ideas?

2 Answers 2


Paste special doesnt always work in every browser. IE is the best, but there are steps to follow to get it to work for Firefox mentioned in this answer

  • Thanks Will. I'm not sure that modifying all the users Firefox installations is the way forward. IE is too slow. Hopefully something came of the "competition". I'll leave the question open for a week then if nothing new comes up I'll modify your answer accordingly. Jun 17, 2013 at 8:43
  • 1
    That FF update still didn't have it working appropriately in my environment. Its a shame that they don't utilize the solutions already created by RTF editors like ckeditor that already have created plugings for their product to work around the browser limitations gracefully.
    – GAG
    Aug 22, 2013 at 12:54
  • In our case, clipboard access is enabled, still paste special does not work in IE9. out of all option only paste as plain text work, rest options do not work. Is there any special setting to do? we are on sp1-hr2
    – Raj Kumar
    Sep 4, 2013 at 16:34

We created an GUI extension for Paste special feature and its shared in SDL Xtensions Community, you can download it from below path

Paste Special Cross Browser Extension

  • Hi Rajkumar, I have installed "Paste special cross browser extension" on my SDL Tridion 2011SP1HR2 instance. "Paste from word" button doesnt seems to be working as expected! It doesnt retain the formatting with text when i copy from word document. Do you have any suggestion what could be the issue?
    – ARRX
    Jun 30, 2015 at 12:09
  • do you see any JS error in firebug?
    – Raj Kumar
    Jul 1, 2015 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.