3

I'm unsure why seeing error "File/folder does not exists!" when attempting to load metadata.xml with run-etl-job command, as the folder exists and the dedicated fredhopper account has read/write access to it. Any thoughts?

Environment details

  • Fredhopper 7.5, revision 19
  • Java 1.8.0_141 x64
  • Fredhopper instance name is ExperienceOptimization

Further details

  • bin\deployment-agent running from command line
  • Command syntax to load metadata.xml as below

    bin\run-etl-job STJob.kjb "-DINSTANCE=ExperienceOptimization" "-DTRIGGER=load-data" "-DUNIVERSE=catalog01" "-DEXECUTIONPATH=C:\fredhopper75\data\instances\ExperienceOptimization\custom"

  • etl instance kitchen.log details

INFO 23-07 19:26:28,924 - Kitchen - Logging is at level : Basic logging

INFO 23-07 19:26:28,939 - Kitchen - Start of run.

INFO 23-07 19:26:29,189 - STJob - Start of job execution

INFO 23-07 19:26:29,210 - STJob - Starting entry [Move Files]

ERROR 23-07 19:26:29,220 - Move Files - File/folder [C:\fredhopper75\data\instances\ExperienceOptimization\custom../../../../ExperienceOptimization/data/fas-xml-incremental/catalog01/] does not exists!

INFO 23-07 19:26:29,224 - STJob - Finished job entry [Move Files] (result=[false])

INFO 23-07 19:26:29,225 - STJob - Job execution finished

INFO 23-07 19:26:29,226 - Kitchen - Finished!

ERROR 23-07 19:26:29,227 - Kitchen - Finished with errors

INFO 23-07 19:26:29,227 - Kitchen - Start=2017/07/23 19:26:28.939, Stop=2017/07/23 19:26:29.227

INFO 23-07 19:26:29,227 - Kitchen - Processing ended after 0 seconds.

  • Folder "C:\fredhopper\ExperienceOptimization\data\fas-xml-incremental\catalog01" exists and have given the Everyone group read/write access filesystem screenshot
  • Same error recurs after removing previous install and reinstalling Fredhopper.
  • Fredhopper cluster created via topology.txt, custom directory created, trigger-types.xml and business.xml added to the config directory of ExperienceOptimization.
  • jars from documentation added to the custom folder of ExperienceOptimization.
  • Query server restarted and confirmed to be running via `"http://localhost:8177/instance/ExperienceOptimization/process/qserver/verb/status"
  • When browsing to "http://localhost:8180/fredhopper/admin/", see status message "business manager will be available when the indices are loaded" (this is expected, as no data has been loaded yet)
1

Since this is Java, you should either use double backslashes or use forward slashes. So this command should work for you:

bin\run-etl-job STJob.kjb "-DINSTANCE=ExperienceOptimization" "-DTRIGGER=load-data" "-DUNIVERSE=catalog01" "-DEXECUTIONPATH=C:/fredhopper75/data/instances/ExperienceOptimization/custom"
  • Many thanks Peter. Moving answer flag to this answer as I am able to run the default STJob.kjb file using forward slashes in the -DEXECUTIONPATH param. Also note a trailing forward slash is required as below "-DEXECUTIONPATH=C:/fredhopper75/data/instances/ExperienceOptimization/custom/" – Terry Kim Aug 15 '17 at 20:19
1

I'm also completely stuck at this point as well. I've just managed to resolve this and I believe there is a problem within the STJob.kjb

Find the section within the STJob.kjb e.g.

  <fields>
    <field>
      <source_filefolder>${EXECUTIONPATH}..&#47;..&#47;..&#47;..&#47;${INSTANCE}&#47;data&#47;fas-xml-incremental&#47;${UNIVERSE}&#47;</source_filefolder>
      <destination_filefolder>${EXECUTIONPATH}..&#47;..&#47;${INSTANCE}&#47;data&#47;xml&#47;incoming&#47;batch&#47;</destination_filefolder>
      <wildcard>.*\.xml$</wildcard>
    </field>
  </fields>

Change this to the following

  <fields>
    <field>
      <source_filefolder>D:\fredhopper\data\instances\liveindexer\data\fas-xml-incremental\catalog01</source_filefolder>
      <destination_filefolder>D:\fredhopper\data\instances\liveindexer\data\xml\incoming\batch</destination_filefolder>
      <wildcard>.*\.xml$</wildcard>
    </field>
  </fields>

In my case, my instance name is liveindexer - just change yours to ExperienceOptimization and change your drive letter to C:\

My log now says the following

INFO  24-07 10:42:06,201 - Kitchen - Logging is at level : Basic logging
INFO  24-07 10:42:06,205 - Kitchen - Start of run.
INFO  24-07 10:42:06,250 - STJob - Start of job execution
INFO  24-07 10:42:06,258 - STJob - Starting entry [Move Files]
INFO  24-07 10:42:06,265 - STJob - Starting entry [Success]
INFO  24-07 10:42:06,266 - STJob - Finished job entry [Success] (result=[true])
INFO  24-07 10:42:06,266 - STJob - Finished job entry [Move Files] (result=[true])
INFO  24-07 10:42:06,266 - STJob - Job execution finished
INFO  24-07 10:42:06,267 - Kitchen - Finished!
INFO  24-07 10:42:06,267 - Kitchen - Start=2017/07/24 10:42:06.205, Stop=2017/07/24 10:42:06.267
INFO  24-07 10:42:06,267 - Kitchen - Processing ended after 0 seconds.
  • Noting that hardcoding the path to catalog01 also resolved issue for me, many thanks. – Terry Kim Jul 24 '17 at 11:02
  • Glad to hear that Terry. Everything is working for me now. Seeing content in my Business Manager now. – Tom Simm Jul 24 '17 at 11:13
-1

It's known issue there is a problem with the smarttarget_api_extension.jar that comes with SDL Web 8, so you can work around it by using the one from 2014 SP1.

Copy the smarttarget_api_extension.jar from Installation media folder of Tridion 2014 SP1 to your fredhopper \custom directory or Contact SDL Support to get the right smarttarget_api_extension.jar.

I hope that it helps you to resolve your issue.

  • I'm also experiencing this same issue Velmurugan. Using the .jars from Tridion 2014 SP1 also did not fix this issue (for me) – Tom Simm Jul 24 '17 at 10:23
  • Also saw that removing jars did not resolve issue, thanks. – Terry Kim Jul 24 '17 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.