0

We have a DD4T based application, Our Sites gets down frequently then just comes up after few minutes.

Also When we recycle the app pool, everything starts working just fine. It seems we are losing the connection to the Discovery service. I don't know why but this is happening.

Please see more error info :enter image description here

5
  • Please add versions - Tridion, DD4T, etc
    – Nuno Linhares
    Commented Jul 28, 2017 at 7:58
  • See github.com/dd4t/DD4T.Core/issues/100 Commented Jul 28, 2017 at 10:19
  • It's known issue with DD4T 2.0, seems quite very often application recycle or caching refreshes happening. Fix for concurrency issue in JSONSerializerService
    – Velmurugan
    Commented Jul 28, 2017 at 15:03
  • @NunoLinhares We are using DD4T 2.1.4 for DD4T.model , So 2.1 for DD4T and web 8 for tridion. Commented Jul 31, 2017 at 7:14
  • @Velmurugan We are using DD4T 2.1 Commented Jul 31, 2017 at 7:18

1 Answer 1

1

Fix for concurrency issue in JSONSerializerService

https://github.com/dd4t/DD4T.Model/pull/33/commits/ff96b151f06f242989449aa9f84ae7408f358db6

2
  • Thanks @Velmurugan ,I am just wondering then how it is working just fine for other application which are using same 2.1.4 for DD4T.Model Commented Jul 31, 2017 at 7:16
  • I believe this issue not appearing for all the applications, sometimes it's strange it's not able to reproduce, it would be because of heavy load on the website or based on custom caching functionality or frequent deployment
    – Velmurugan
    Commented Aug 1, 2017 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.