1

I'm getting the below error in the Content Service, any idea why this is coming?

ERROR JMSCacheChannelConnector - JMS Exception occurred during reception of event. Attempting setting up JMS connectivity again javax.jms.JMSException: Failed to build body from bytes. Reason: java.io.InvalidClassException: com.tridion.cache.CacheEvent; local class incompatible: stream classdesc serialVersionUID = -8109545960597551825, local class serialVersionUID = 1252887747292650827 at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:36) ~[activemq-client-5.12.1.jar:5.12.1] at org.apache.activemq.command.ActiveMQObjectMessage.getObject(ActiveMQObjectMessage.java:198) ~[activemq-client-5.12.1.jar:5.12.1] at com.tridion.cache.JMSCacheChannelConnector.handleJmsMessage(JMSCacheChannelConnector.java:219) ~[cd_cache-8.1.1-1012.jar:8.1.1-1012] at com.tridion.cache.JMSCacheChannelConnector$2.onMessage(JMSCacheChannelConnector.java:84) [cd_cache-8.1.1-1012.jar:8.1.1-1012] at org.apache.activemq.ActiveMQMessageConsumer.dispatch(ActiveMQMessageConsumer.java:1393) [activemq-client-5.12.1.jar:5.12.1] at org.apache.activemq.ActiveMQSessionExecutor.dispatch(ActiveMQSessionExecutor.java:131) [activemq-client-5.12.1.jar:5.12.1] at org.apache.activemq.ActiveMQSessionExecutor.iterate(ActiveMQSessionExecutor.java:202) [activemq-client-5.12.1.jar:5.12.1] at org.apache.activemq.thread.PooledTaskRunner.runTask(PooledTaskRunner.java:133) [activemq-client-5.12.1.jar:5.12.1] at org.apache.activemq.thread.PooledTaskRunner$1.run(PooledTaskRunner.java:48) [activemq-client-5.12.1.jar:5.12.1] at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.8.0_92] at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.8.0_92] at java.lang.Thread.run(Unknown Source) [na:1.8.0_92] Caused by: java.io.InvalidClassException: com.tridion.cache.CacheEvent; local class incompatible: stream classdesc serialVersionUID = -8109545960597551825, local class serialVersionUID = 1252887747292650827 at java.io.ObjectStreamClass.initNonProxy(Unknown Source) ~[na:1.8.0_92] at java.io.ObjectInputStream.readNonProxyDesc(Unknown Source) ~[na:1.8.0_92] at java.io.ObjectInputStream.readClassDesc(Unknown Source) ~[na:1.8.0_92] at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source) ~[na:1.8.0_92] at java.io.ObjectInputStream.readObject0(Unknown Source) ~[na:1.8.0_92] at java.io.ObjectInputStream.readObject(Unknown Source) ~[na:1.8.0_92] at org.apache.activemq.command.ActiveMQObjectMessage.getObject(ActiveMQObjectMessage.java:191) ~[activemq-client-5.12.1.jar:5.12.1] ... 10 common frames omitted

  • I haven an idea, it happens because something is wrong ;o). It would be good if your edit your question and provide a bit more details, see tridion.stackexchange.com/help/how-to-ask for some details on how to ask a good question. – Bart Koopman Aug 10 '17 at 11:21
2

Most likely reason is that you have version mismatch between the JAR's in your deployer service and content service.

This can happen when you apply hotfixes to a service. When faced with a similar issue in the past I've made sure to grab a hotfix version that includes both services to make sure they are aligned.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.