0

When I am trying setup DXA 1.2 version I am getting the below error. I tried all possible solutions given by Tridion Stack exchange.

  1. My OS is Windows 7 Enterprise 64 Bit.
  2. JRE 1.8.0_144 version is installed.
  3. Microsoft Visual C++ 2010 SP1 Redistributable is installed.
  4. Copied all required JARS and DLLS.
  5. I have Valid CD License files.
  6. I placed correct version of netrtsn.dll and xmogrt.dll in bin folder.

After doing all the above also I am getting below error.

[DllNotFoundException: Unable to load DLL 'xmogrt': The specified module could not be found. (Exception from HRESULT: 0x8007007E)] Codemesh.JuggerNET.NativeInterface.GetJvmLoader(Int32 ctorVersion, String configFile, String vers, String conf, String reserved, Boolean bEnvOverrides, Boolean bDefaultJvm, Int32 traceFacility, Int32 traceLevel, Int32& error) +0 Codemesh.JuggerNET.JvmLoader.GetJvmLoader(Boolean bEnvOverrides, Boolean bDefaultJvm, TraceFacility fac, TraceLevel level) +138 Codemesh.JuggerNET.JvmLoader.GetJvmLoader() +49 Codemesh.JuggerNET.NativeInterface.ToJavaStringPinning(String str, Int32 length, IntPtr& result) +69 Codemesh.JuggerNET.NativeInterface.ToJavaString(String str) +80 Codemesh.JuggerNET.JavaMethodArguments.Add_string(String str) +153 Codemesh.JuggerNET.JavaMethodArguments.Add(Object obj, Type type) +249 Codemesh.JuggerNET.JavaMethodArguments.Add(Object obj) +44 Org.Slf4j.LoggerFactory.GetLogger(String name) +139 Tridion.ContentDelivery.Web.Utilities.Logger..ctor(String loggerName) +56 Tridion.ContentDelivery.Web.Utilities.LoggerFactory.GetLogger(String loggerName) +52 Tridion.ContentDelivery.AmbientData.HttpModule..cctor() +81

Then I tried solution mentioned in the following URL Unable to load DLL 'xmogrt': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Followed the instructions given in the answers removed xmogrt.dll and placed in windows/SysWOW64, Still same error.

When I placed xmogrt.dll in windows/system32 the above error gone and now getting;

Unable to locate a valid Tridion Home directory, see Tridion event log

No logs are generated.

Then I tried instructions given in the follwoing link Getting Error message "Unable to locate a valid Tridion Home Directory" while accessing Contact Profilesync.aspx page

Still I am unable to resolve the error.

Same code base is working on other developer system.

What I am missing, Do we have any other options for resolving xmogrt DLL error.

  • Where did you get your xmogrt dll? If you had transferred it as a zip over network, make sure you unblock the zip property before extracting it. This is first guess. – Vikas Kumar Aug 25 '17 at 15:17
  • Thank you for quick response, I downloaded from my project SVN – Prasanna K Gollamudi Aug 25 '17 at 15:33
  • do you have proper access on bin folder? try giving everyone and then check. if works. then remove everyone and give access to App-pool identity user. – Raj Kumar Aug 27 '17 at 11:51
1

Possibly still you are somewhere still not using right DLL versions, Try following steps to fix this issue.

  • Uninstall to revert all your changes
  • Install Java JRE 1.8 (x64) bit, type java -version in the command prompt to ensure Java is working as expected, try to restart system also double check is there any other Java version installed in the system find and remove
  • Download and install the Microsoft Visual C++ 2010 SP1 Redistributable (x64) bit
  • To install a 64-bit .NET Web application, access the x86_64\ In the installation media folder Content Delivery\roles\api\DotNET copy to the bin folder.
  • For MS SQL Database required sqljdbc42.jar for Java 8 not sqljdbc4.jar

I hope it will resolve your issue.

  • Hi Velmurugan, Thank you for detailed instructions, After doing the above steps Still i am facing same issue, In other system I was able to execute the application and Assets are loading but page cannot be displayed error is coming after view rendering. – Prasanna K Gollamudi Aug 31 '17 at 15:20
1

Like the answer already given, I think it can only be something related to the netrtsn.dll and xmogrt.dll you are using. They are either blocked or not of the correct version is what I still suspect.

If you check out the first two answers of: Error while installing Tridion 2013 SP1 CDS: Unable to load DLL 'xmogrt' you see a few resolutions that can be helpful and should be checked. The other two answers given there can also be of help, but that is repeating what has already been answered here.

But most important to mention is that you should not place these DLLs in your windows/SysWOW64 or windows/System32 directories, they belong in the bin folder of your web application. Else you are creating a system global depoendency which will only be harder to solve, so please make sure they are deleted from the system folders before trying to solve it any further.

note: If all else fails, maybe it is an option to consider upgrading to Web 8 and get rid of the whole in-process and JuggerNET trouble. SDL Tridion 2013 SP1 is nearing its end of support and we are currently on DXA 1.7, with the release date of DXA 2.0 nearing soon also ;o).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.