4

On the Content Manager Explorer of a SDL Web 8.1 instance I get an error when I use the "View on Site" button on any page.

On the same instance this button used to work.

I tried to close&open the browser, and tried on a different machine but the issue remains.

This is the error message from the browser console:

Uncaught ReferenceError: ko is not defined
    at eval (/WebUI/Editors/Base/Libraries/Knockout/knockout.bindinghandlers.js:1)
    at eval (<anonymous>)
    at Function.globalEval (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:1)
    at JsFileHandler._render (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:3)
    at JsFileHandler.o.render (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:3)
    at Function.o.renderWhenLoaded (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:3)
    at eval (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:3)
    at Object.eval (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:3)
    at c (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:2)
    at Object.fireWith (/SDL/Common/Library/Core/Packages/SDL.Client.Core.js:2)
/WebUI/Editors/Base/Libraries/Knockout/knockout.bindinghandlers.js:1 

What could cause this issue?

  • After a restart of IIS and all content manager services the problem was resolved. I do not know what the root cause was. – Jan H Sep 8 '17 at 13:46
  • recently any GUI extensions/hotfix deployment anything happened on CME server? – Velmurugan Sep 10 '17 at 18:46
  • @Velmurugan I have an ECL extension, but that has been stable for a while. – Jan H Sep 11 '17 at 6:03
2

There is a hotfix available for this: https://gateway.sdl.com/apex/communityknowledge?articleName=000006841

It is also fixed in 8.5 version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.