5

I have installed SDL Web 8.5 and imported the Content Port for DXA 2 CTP2. In my content manager, I see the DXA publications. I had also set up staging and live environments and followed the relevant steps to get the necessary DXA entries in topology manager, so I'd expected publishing to "just work", but some days you need more than unfounded optimism.

When I look in the properties of the 400 Publication, and go to the Publishing tab, I'd expected to be see a Business Process Type selected, or at least to be able to select one, but what I see is this:

Empty BPT Dropdown

Over in the notifications area, I see this:

enter image description here

I'm drawn to the conclusion that these two things are in some way related, but of course, it ain't necessarily so.

Why can't I see Business Process Types in this dropdown, when the two BPT's from DXA are clearly visible in the tree?

Might this have something to do with initially installing the CME on port 81 and topman on 82, and then later moving these to port 80 and relying on the host headers? (I also updated the ttmCmEnvironment and TRIDION_TTM_SERVICEURL to match.)

I don't think I've done anything else to depart from the beaten track, but who knows? Any hints are welcome.

I've tried to find borked service traffic with Fiddler, but nothing obvious jumps out at me. Where else should I be seeking clue?

  • I think the dxa install script creates a new CD environment. Have you checked if that is configured correctly as well? – Quirijn Oct 4 '17 at 10:28
  • Always better to delete the DefaultWebsite in IIS before start installing the SDL Web, I believe core service endpoint something still pointing as port 81 instead of 80. worth to check the SDL Web\bin\ folder configs of the Tridion host. or search to find out 81 port somewhere present in the configs. Clearly, shows error Unable to connect to the remote server. – Velmurugan Oct 4 '17 at 20:26
5

I suspect that the two things are related.

When you run the installer, the Topology Manager service URL is set as an environment variable called TRIDION_TTM_SERVICEURL.

You’ll need to update that value (to the URL on port 81) and then restart your server.

Update: As you've updated the CME URL (from port 81 to port 80), you'll also need to update the value of the Tridion.WCF.RedirectTo in the following file: \%TRIDION_HOME%\web\WebUI\WebRoot\web.config

  • 1
    Indeed, Jonathan - as you know - when we fixed the RedirectTo, it started working. #tridionMVP retreat collaboration FTW – Dominic Cronin Oct 5 '17 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.