3

In one of our environment value for Staging is set to true in _all.json file, because of that Experience Manager button got enabled. But I need to set the Staging value to false in order to disable the Experience manager button.

Do we have any setting in CMS to update the value to false in _all.json file?

I thought of taking below steps:

  1. I can localize Environment Configuration component, located in: \100 Master\Building Blocks\Settings\Core\Admin\Environment Configuration and update the wrong CMS URL value
  2. Publish Static Bootstrap TBB is responsible for generating the _all.json file, if I could customize it based on our requirement.

Please suggest on above steps or we have other options. I am using Tridion 2013 SP1.

4

In SDL Web 8.x, using Topology Manager, DXA will check if XPM is enabled by checking the Discovery service. So, if you have registered the microservices needed for XPM for your specific purpose or not, it will enable/disable XPM by setting Staging to true or false.

In Tridion 2013 (this is what you are using), it will check the Publication Target to which you are publishing. If that Publication Target has XPM editing enabled, it will set the Staging property to true.

For more insights in this, check the DXA template source code where this happens: https://github.com/sdl/dxa-content-management/blob/release/1.5/Sdl.Web.Tridion.Templates/Common/Utility.cs#L66

  • Thank you @Harald , Is this Staging property set only be done by checking the "Enable for Inline Editing" checkbox in Target type or it can be done by other ways too. Because I can see that in our environment that checkbox is not checked for Staging Target Type, but Value for Staging is set to True in _all.json. We can edit the value directly in _all.json file to false but again on publishing the Settings the Staging value is getting stored as true. – SDLBeginner Oct 31 '17 at 11:41
  • 1
    @SDLBeginner the process is exactly as Harald describes, if the Publication Target is enabled for inline editing, then the value will be set to true (see also docs.sdl.com/LiveContent/content/en-US/…). If you mention it isn't enabled and you did republish the Publish Settings Page and the value is not changing, there might be something wrong in your CMS (the Appdata for XPM might still be set, or you are looking at the wrong Publication Target). Don't try to find other ways of disabling it, this is it. – Bart Koopman Oct 31 '17 at 12:24
  • Thank You @BartKoopman and Harald, now i got clear idea on this. – SDLBeginner Nov 2 '17 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.