5

I am running into an issue with tracking+redirecting links opened in an email sent via Outbound Email. The tracking link looks like this:

https://.../outboundemail/Tracking/?a=L&p=$5vdNbzUvsknlTVoC-kAsbSJELY_wvHJA-Zxtvh5zWcV8X_vwKPkMID_fB8EHQeYBG5Np5LD9xPVa_czNUBGndAwcV2zfEkwdW9Ka7BOaV-7ArVnnLBZ83z$$

The route /outboundemail/Tracking maps to an MVC controller action, which only contains the following code:

Handler handler = new Handler(System.Web.HttpContext.Current.Request);
Response.Redirect(handler.Url);

where Handler is from Tridion.OutboundEmail.ContentDelivery.Tracking. The handler URL always is a redirect to the error page URL, as it is configured in the cd_audiencemanager_conf.xml element /Redirect/GeneralError.

My questions are:

  • to how best troubleshoot this, which log files to look into
  • wanting to understand how the Tridion handler uses the value of the p-parameter to determine a URL. Is there synching going on under the hood from CM->CD side, is the URL in a CD DB somewhere?
  • Additionally, I also see that, even though I have a /Redirect/GeneralError element in the config file containing Error.html, the handler Url is always /Redirect/GeneralError, so it is not actually using the value in case of an error. – Para Jaco Nov 16 '17 at 8:25
  • Please edit your question to provide additional information, you should NOT use the comments for this. – Bart Koopman Nov 16 '17 at 9:00
1

The URL is valid and points to an absolute URL. So there's no link resolving needed and it should just be redirected directly.

So most likely you are getting an error that isn't related to the actual handling, but something else (such as not being able to load the configuration file).

To find the error, look in the log file configured for either your website (if using in-process) or the Audience Manager micro-service (if you are using that).

As for how it uses the value of the "p" parameter, it's using a simple encryption mechanism to store the values that it needs in one parameter. So the data is all there, just obfuscated.

  • Thanks Peter, after deploying our latest release which contains an complete/updated cd_audiencemanager_conf.xml, it is working now. – Para Jaco Nov 29 '17 at 17:47
  • Glad it was fixed! Perhaps you'd like to accept my answer, so others who might have the same or similar issues can see what worked for you? :) – Peter Kjaer Dec 1 '17 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.