6

When porting pages from our [05 Website] publication the Business Process information is being included and when importing into the next environment it is trying to overwrite the (different) Business Process for the publication. This generates an error:

Item /webdav/...[path to business process]... cannot be imported because it is absent on import TCM and its content was not exported to the package

which is expected as it doesn't exist on the target CMS. This can be skipped, but the result is that the Business Process in the target environment is set to 'none' and has to be changed back to its correct value in the dropdown in the publishing tab of the properties of the Publication.

Is there a way to either stop the Business Process information from being exported, or alternatively stop it being imported? With the dependency filters unselected it still includes the Business Process (it attempts to import it into the target environment), although in this situation it doesn't set it to 'none' when skipped.

Any information or help would be greatly appreciated.

7

Three options you may want to consider:

  1. Rename the BPT in the source system (to the same name as the one used in the destination) before doing the export and then just exclude it from the import, to ensure that it's not updated.

  2. Use the Mappings file to change the name (WebDav path) of the BPT during the import. More details in the Changing mappings section of the online docs.

  3. Write a Core Service tool to update the BPT back to the correct one on each of the affected Publications, following the import, and then delete the new, unwanted BPT. However, I suspect that the import may fail if the Topology Type in the source's BPT is not available in the destination system's Topology Manager configuration.

I also suspect that there may be a bug in the Content Porter client that makes you think that the BPT will be updated even when it is excluded with the filters (and not selected). However, I seem to remember that it isn't actually updated (i.e. the settings for each purpose remain the same). Obviously proceed with caution with this though!

| improve this answer | |
  • #2 works nicely, but I will look at renaming the BPT to a more generic name throughout our environments (#1) as a more permanent solution. I don't really want our users editing mappings files as they don't have the technical understanding to do so. – ThatITBloke Jan 5 '18 at 10:12
  • Excellent. Glad it worked. I’m in the middle of writing a “Topology Manager best practices” blog post and using consistent names for BPTs and Topology Types is one of them! – Jonathan Williams Jan 5 '18 at 10:16
  • I haven't used Content Porter much since BPTs were introduced and just found the same issue (and likely solution). How did that blog post go, @Johnathan? :-) And is there a setting or way to select items to have Content Porter ignore the BPT in the first place? – Alvin Reyes Nov 20 at 20:15
  • Haha. I think it became my talk at TDS 2018, rather than a blog post 😁 – Jonathan Williams Nov 21 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.