1

We have just installed the CTP 2.0 Model Service (CD Microservice) from the official SDL documentation: Model Service Documentation

After successfully installing the service and calling the PageModel endpoint, the modelData returned is null. Therefore the DXA webapp throws exceptions.

Following endpoint was called:

http://172.19.3.2:8998/PageModel/tcm/1206/en?include=INCLUDE

The Service returns a small JSON without modelData:

{
  Id: "tcm:1206-368946-64",
  Meta: { },
  Title: "000 Home"
}

The nullpointer exception is thrown because the modelData is null:

exception modelData null

I double checked the configurations and also increased the logging up to DEBUG but had no luck finding any configuration or connection issues. If I add ?raw=true to the PageModel request, all my Components that are on my Page are getting listed in the JSON.

  • Con you confirm the entire DXA example website is published, including the settings, include Pages and dynamic Component Presentations etc.? – Bart Koopman Jan 26 '18 at 13:30
  • Yes its all published. The page was running with only few issues in DXA1.7 but we created a 2.0 branch for development since we have some issues that are going to be fixed with 2.0 and currently blocking our UAT. – S. Gabriel Jan 26 '18 at 13:42
  • Since you mention DXA 1.7 this is an upgrade, correct ? Can you verify that you published all of your pages using the new 2.0 DXA Template Building Blocks and not the legacy ones ? I do recall that the 2.0 model service expects items to be published in the new json format. – Harald Hoffelinck Jan 26 '18 at 13:53
  • well actually the CTP 2 release has data model compatibility in there already and should be able to deal with both the old and the new JSON format (that wasn't available in CTP 1 indeed), but I would suggest that the question is edited and updated with this additional information, to get to a correct answer we need to know if this is about the DD4T JSON (from DXA 1.7) or the new DXA R2 JSON indeed. – Bart Koopman Jan 26 '18 at 14:08
  • We are running the 1.7 TBB's and didnt upgrade them yet. If you say its mandatory to upgrade the Building Blocks to 2.0, then we will do it on monday. – S. Gabriel Jan 26 '18 at 15:59
0

The TBB's needed to be upgraded to DXA R2 JSON model. Once i have upgraded everything the output was correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.