7

I've been trying to port components and am currently continually stuck at the error below.

enter image description here

We have a 153MB package that contains all components from different publication levels in the blueprint.

  1. I ran an import to get some 100 level components in. This worked fine.
  2. I run the import again to get 200 level components in and it always fails with the above.

I've checked on the CM server and during a failed import I can see the packages getting partially created (top one):

enter image description here

If this is simply a timeout problem:

  1. Why didn't it occur for my first import?
  2. Which config needs adjusting to extending - by default the service has a 30 minute timeout doesn't it(?) and my error occurs < 1 minute.

This doesn't affect other smaller imports which work as expected. I've also reproduced this behaviour on two different CM servers using the same package.

Is there any Import Export service logging on the server I can able?

I was reading this post which seems tantalisingly similar but I don't understand why the same package can work once and then fail?

3

Let me try answering your questions first:

Why didn't it occur for my first import

That depends on package. :D

I hope you know that 100 of one type items in Tridion are never the same as 100 of other items (neither by size of packages, complexity, or even number of action it takes over database to create them during import).

Which config needs adjusting to extending - by default the service has a 30 minute timeout doesn't it(?) and my error occurs < 1 minute.

Actually import/export service uses default timeout for database connections defined in MMC snapin console. Increasing timeouts for executing short queries from one minute to 30 mins should fix your issue.

enter image description here

However, I just want to point that this is patching the problem, not fixing it. Most probably your CM database is slow, so it reflects on database intensive operations (like creating items during import). For checking logging issues related to ImportExport service, please check following section in TridionContentManager.config:

enter image description here

Also you can always check logs of Content Porter itself for additional information.

  • Some great info there Marko - Ill take a look and let you know. – Neil Feb 15 '18 at 17:16
3

It seems that the tineout occurs while uploading the package to the server (through the Import/Export Service stream upload endpoint).

When uploading, the package is temporarily stored on the server’s filesystem, so DB timeouts are not applicable here. The stream upload endpoint does have send/receive timeouts, though. See the WCF configuration in webservices\web.config (note that CP client also has a client-side WCF config).

It may be that uploading a subset of the items does work, because the CP client will then create a smaller package.

  • Yeah - Had considered that but I know nothing about the created content and it was numerous dependencies that I'm relying upon CP to find for me. I have no way to know which components I can leave off my export :( – Neil Feb 16 '18 at 8:42
  • I just wanted to clarify “why didn’t it occur for my first import” :-) – Rick Pannekoek Feb 16 '18 at 11:34
1

Interestingly you ask: If this is simply a timeout problem?

I'm almost certain that when we are talking about database driven systems and we assume the network between the client, server and the database isn't the issue, it actually never really is simply a timeout problem.

It is in my opinion most likely a database maintenance problem, certainly considering that you have been running multiple imports, your database statistics are most likely not up to date and your database needs maintenance (i.e update statistics and possibly optimize indexes).

On MS SQL Server you might already see a huge difference if you run exec sp_updatestats;, or Oracle there are some scripts that can help.

Note Rick's answer, the database might not be in play here though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.