7

I am facing one issue while setting up the New Domain in the existing Topology. It doesn't allow me to update the PrimaryMappedUrl in the existing Topology.

One approach is to:

  • Unpublish all items from that Publication
  • Remove the Mapping & add a new Mapping

But I can't unpublish the items from PROD env.

Is there any alternate way to do that?

5

To update the domain you can use this command:

Set-TtmWebsite -Id Your_Website_ID -Baseurls @("https://new-domain-host")
3

In addition to the running the Set-TTmWebsite command noted by Velu, you'll also need to resync the configuration to the Content Delivery environment using PowerShell:

Sync-TtmCdEnvironment -Id [Content_Delivery_Environment_ID]
  • Are you sure that is always necessary? I was under the impression that synchronization would happen automatically in most cases. – Quirijn Feb 22 '18 at 17:07
  • I've always explicitly run it after making any changes. The SDL online documentation is unclear, but it only seems to be mentioned after using Import-TtmCdStructure there, so I suspect that you may be right! I'll test it out next time I'm playing with Topology Manager and report back. – Jonathan Williams Feb 23 '18 at 10:28
  • 1
    Changes should indeed be propagated to the Discovery Service automatically and it should normally not be needed to use the Sync-TtmCdEnvironment cmdlet. – Rick Pannekoek Feb 23 '18 at 14:49
  • Thanks for confirming, Rick. Presumably this sync only needs to needs to be done after using Import-TtmCdStructure then, as that's the only place it's mentioned in the online docs. – Jonathan Williams Feb 26 '18 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.