0

I have downloaded the si4t-se-1.2.jar source file from GitHub (https://github.com/SI4T/SI4T/tree/develop/storage-extensions) and compiled class files in Eclipse and created a new jar file of the same putting some extra loggers. When I tried to publish a Page after this, I am getting some exceptions as below.

org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'JPASearchDAOFactory' is defined
at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanDefinition(DefaultListableBeanFactory.java:677)
at org.springframework.beans.factory.support.AbstractBeanFactory.getMergedLocalBeanDefinition(AbstractBeanFactory.java:1180)

Anyone had this issue before or any insights to what I am missing? Thank you.

1

AFAIK - It looks like some dependencies missing.

Try to troubleshoot by following steps.

  1. In the pom.xml add this maven-dependency-plugin and rebuild copy the dependencies files from lib folder.
             <plugin>
                <artifactId>maven-dependency-plugin</artifactId>
                <executions>
                    <execution>
                        <id>install</id>
                        <phase>install</phase>
                        <goals>
                            <goal>copy-dependencies</goal>
                        </goals>
                        <configuration>
                            <outputDirectory>${project.basedir}/lib</outputDirectory>
                            <excludeGroupIds>com.tridion,org.slf4j,commons-io,commons-codec,commons-logging</excludeGroupIds>
                        </configuration>
                    </execution>
                    <execution>
                        <id>package</id>
                        <phase>package</phase>
                        <goals>
                            <goal>copy-dependencies</goal>
                        </goals>
                        <configuration>
                            <outputDirectory>${project.basedir}/lib</outputDirectory>
                            <excludeGroupIds>com.tridion,org.slf4j,commons-io,commons-codec,commons-logging</excludeGroupIds>
                        </configuration>
                    </execution>
                    <execution>
                        <id>compile</id>
                        <phase>compile</phase>
                        <goals>
                            <goal>copy-dependencies</goal>
                        </goals>
                        <configuration>
                            <outputDirectory>${project.basedir}/lib</outputDirectory>
                            <excludeGroupIds>com.tridion,org.slf4j,commons-io,commons-codec,commons-logging</excludeGroupIds>
                        </configuration>
                    </execution>
                </executions>
            </plugin>
 

Note:

If you are planning to install and keep the deployer extension jars under services/solr-search folder then ensure to remove the spring boots jars.

  1. Ensure your cd_storage configured correctly as expected.

  2. Also, ensure your deployer service all the used dependencies jars already exist in the lib folder those versions are should be matched with si4t-se-1.2 pom.xml file.

  3. Enable SI4T DEBUG logger in logback.xml by adding this following section to see the detailed errors where it's causing.

`   <appender name="rollingSI4TExtensionsLog" class="ch.qos.logback.core.rolling.RollingFileAppender">
        <rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">
            <fileNamePattern>${log.folder}/si4t-extentions.%d{yyyy-MM-dd}.log</fileNamePattern>
            <maxHistory>${log.history}</maxHistory>
        </rollingPolicy>
        <encoder>
            <charset>${log.encoding}</charset>
            <pattern>${log.pattern}</pattern>
        </encoder>
        <prudent>true</prudent>
    </appender>


   <logger name="com.tridion.storage.si4t" level="${log.level}" additivity="false">
    <appender-ref ref="rollingSI4TExtensionsLog" />
   </logger>

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.