3

Please find a screenshot below:

enter image description here

This is a .Net application. I'm using Razor and DWT Templates.

Here is the source of the published page (taken from the pastebin URL in the comments below) which seems to contain the correct XPM tags:

<html>
<head>
  Inline page
</head>
<body>
<tcdl:ComponentPresentation type="Embedded" componentURI="tcm:18-9360" templateURI="tcm:18-9357-32"><span><!-- Start Component Presentation: {"ComponentID" : "tcm:18-9360", "ComponentModified" : "2018-03-27T00:43:06", "ComponentTemplateID" : "tcm:18-9357-32", "ComponentTemplateModified" : "2018-03-27T12:59:23", "IsRepositoryPublished" : false } -->
  <span><!-- Start Component Field: {"XPath":"tcm:Content/custom:InlineEditingTestschema/custom:Title[1]"} -->
    TEst
  </span>
  <span><!-- Start Component Field: {"XPath":"tcm:Content/custom:InlineEditingTestschema/custom:Description[1]"} -->
    <p>cdasfasfsd</p>
<p>fsdfsdfsdfsd</p>
<p>fsdfsdfsf</p>
  </span>
</span></tcdl:ComponentPresentation>
<script type="text/javascript" language="javascript" defer="defer" src="http://localhost:81/WebUI/Editors/SiteEdit/Views/Bootstrap/Bootstrap.aspx?mode=js" id="tridion.siteedit"></script>
</body>
</html>
4
  • Hi Thoufik, Please provide some more information like - XPM tags that you have used, configurations and also the log. – Sayantan Basu Mar 27 '18 at 6:53
  • Please edit your question and provide the HTML source of the page? – Velmurugan Mar 27 '18 at 8:54
  • use pastebin.com to provide the html source and link URL here – Velmurugan Mar 27 '18 at 9:57
  • After updated tag this is latest source file pastebin.com/1137x7Fz – Thoufik Ahamed Mar 27 '18 at 12:32
3

Try following steps to resolving this issue.

  1. Ensure "Enable inline editing for Page" TBB added in your page template using template builder and then on the right, select SiteEdit Editor URL and set it to the value http://localhost:81/WebUI/Editors/SiteEdit/
  2. In the General tab ensure that Enable for inline editing is selected for Page Template.
  3. Also, ensure that the following comment is inserted into your end of Page Template code.

<!--SITE_EDIT_INIT-->

This will render the missing Page Settings tag as highlighted by @Jonathan.

Hope this helps.

1
2

This looks like your page is created based on "Default Page Template", which, I am quite sure, doesn't have XPM markup. Please change page template to some yours which you know has markup and test again.

Update:

Following documentation explains proper XPM syntax.

Can you please verify that you wrote @@FieldStartMarker@@ and @@FieldEndMarker@@ tags?

2
  • @@FieldValueStartMarker()@@ @@GetFieldValue('Component.Fields.Title', 0)@@ @@FieldValueEndMarker()@@ @@FieldValueStartMarker()@@ @@GetFieldValue('Component.Fields.Description', 0)@@ @@FieldValueEndMarker()@@ this is tag we are using Component Tbb and also i removed default TBB but still same issues persist – Thoufik Ahamed Mar 27 '18 at 8:07
  • Verified as per the shared docs. Updated and published but still no luck. But 1 more concern "Enable inline editing page TBB" should be get part installation but when restoring DB we lost. How we can get TBB ? just uploaded dll "Tridion.SiteEdit.Templating.dll" then we got "Enable Inline Editing Content" TBB same dll needs to use for Page TBB aslo please clarify – Thoufik Ahamed Mar 27 '18 at 12:23
1

Looking at the HTML source that you uploaded to Pastebin (now included in the question), it appears that your missing the XPM markup needed on the page. For example:

<!-- Page Settings: {"PageID":"tcm:9-259-64","PageModified":"2016-08-04T14:43:31","PageTemplateID":"tcm:9-264-128","PageTemplateModified":"2016-10-18T12:37:03"} -->

This is normally found just above the Bootstrap Javascript tag at the bottom of the page.

You may want to check the TBBs and markup that you're using on the Page Template.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.