1

We are using DXA 2.0 and generating website navigation based on these parameters:

  1. Type of Navigation - Localizable - Based on Page and Structure Group titles
  2. Page Template - Redirect Page
  3. Navigation text field - standardMeta/Name, title

and we are using core.NavigationController for generating top, left and breadcrumb navigation in all sections of the website but we are not getting breadcrumb for the one of the sections.

breadcrumb Template:

enter image description here

Breadcrumb Output on 2 different pages :

enter image description here

enter image description here

breadcrumb Entity view

<nav aria-label="breadcrumb">
    <ol class="breadcrumb">
        <c:forEach var="item" items="${entity.items}" varStatus="status">
            <c:if test="${status.index == 0}">
                <li class="breadcrumb-item"><a href="${item.url}">${item.linkText}</a></li>
            </c:if> 
            <c:if test="${status.index > 0 && status.index < entity.items.size() - 1}">
                <c:if test="${fn:indexOf(isNewsDetailPage, 'Y') == -1 || (fn:indexOf(isNewsDetailPage, 'Y') > -1 && status.index < 3)}">
                    <li class="breadcrumb-item"><a href="${item.url}">${item.linkText}</a></li>
                </c:if> 
            </c:if> 
            <c:if test="${status.index == entity.items.size() - 1 && fn:indexOf(isNewsDetailPage, 'Y') == -1}">
                <li class="breadcrumb-item active" aria-current="page"><h1>${item.linkText}</h1></li>
            </c:if> 
            <c:if test="${(fn:indexOf(isNewsDetailPage, 'Y') > -1 && status.index == 3)}">
                <li class="breadcrumb-item active" aria-current="page"><h1>${item.linkText}</h1></li>
            </c:if> 
        </c:forEach>
    </ol>
</nav>
  • 1
    Your question isn't clear and is lacking in details, for instance, which section, what did you try to resolve this, etc.? Update it with more information so you have a better chance of getting help. – Atila Sos Apr 17 '18 at 22:01
  • 1
    You are using a Redirect Page, so this is redirected to what? You leave out a lot of details which make it impossible for us to understand what is happening exactly. I suggest you edit the question and add all the information you can, perhaps add screenshots and explain the configuration behind those, what Page are we seeing, what templates are used, what metadata settings etc. etc. Please understand that we can't see your system and don't know how it is setup, you might think it is default, but there is no such thing as a default setup. – Bart Koopman Apr 18 '18 at 6:00
  • added screenshot of template and the output of two pages – Saurabh Jha Apr 18 '18 at 6:14
  • I'm guessing the first screenshot is the one where your breadcrumb is not working (would be useful if you added some text to explain what is shown and what you expected etc.). Your Breadcrumb CT shows that you have a custom Entity and Region view, maybe interesting to know its changes? I'm also still wondering why you mentioned the Redirect Page, but unfortunately you still didn't explain how that is related. You have to understand that in order to get relevant answers, you have to give people here enough information so they can reproduce your issue and help you finding a solution. – Bart Koopman Apr 18 '18 at 14:18
  • Yes in first screenshot, i am not getting full breadcrumb.. i did not make any change in the page template field. i guess ...it is from demo site (white label site). we do not want to change any of the core views and region that's why we have created custom view and entity .. i am adding the entity view source in the question @BartKoopman – Saurabh Jha Apr 18 '18 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.