1

We have installed Content service, Discovery service, and DXA Model service. Since auto registration for DXA Model service is failing, as per DXA Model Service documentation from GIT Hub added the role directly in CD storage config for discovery service and Content service as follows

<Role Name="ContentServiceCapability" Url="http://system name:9081/content.svc">
    <Property Name="dxa-model-service" Value="http://system name:9083"/>
</Role>

After that as Services are up and running we tried to run the sample DXA application locally, We got the below error

DXA Model Service is not registered; no extension property called 'dxa-model-service' found on Content Service Capability.

When we have validated the DXA Model Service using Postman we got below error

{
    "timestamp": [
        "String",
        "2018-05-29T09:31:29.070+0000"
    ],
    "status": 500,
    "error": "Internal Server Error",
    "exception": "com.sdl.odata.client.api.exception.ODataClientHttpError",
    "message": "Unable to get response from OData service: 404 Not Found\r\n",
    "path": "/"
}

We have Used SDL Documentation along with below blogs

https://velmuruganarjunan.wordpress.com/category/dxa/

https://community.sdl.com/product-groups/sdl-tridion-dx/tridion-sites/tridion-developer/b/weblog/posts/install-model-service-dxa-2-0-as-a-windows-service

Can you please suggest If we are missing any configurations?

  • Did you run the Discovery Service Registration Tool after changing the config? Why/how did auto registration fail? – Rick Pannekoek May 29 '18 at 6:05
  • Below is the log file when I executed Discovery Service Registration Tool 2018-05-28 16:58:22,385 ERROR UpdateCommand - Not able to find builder for capability: ContentServiceCapabilities. Skipping... The Other Services like Context Service, Deployer Service, and Token service got registered without any issues. – Prasanna K Gollamudi May 29 '18 at 6:41
  • share the command what you used to run auto-register of DXA Model service? – Velmurugan May 29 '18 at 7:15
  • I have used the below command executed from discovery service installation folder discovery\config>java -jar discovery-registration.jar update – Prasanna K Gollamudi May 29 '18 at 7:53
  • Hi Prasanna, it will be a lot more useful if you edit your question and add the relevant information like logfiles and commands etc. in there rather than trying to crop it into a comment. That way more people get to see it directly which should improve the likelihood of a sufficient answer. – Bart Koopman May 29 '18 at 12:14
1

DXA Model service error in Postman

The above error occurred as DXA Model service capability is not added to discovery service as ContentServiceCapability node got added by mistake under WebCapabilty node as shown below in cd storage config of discovery service.

<Role Name="WebCapability"> <Role Name="ContentServiceCapability" Url="Computer name:9081/content.svc">; <Property Name="dxa-model-service" Value="Computer name:9083"/>; </Role>

Once removed the ContentServiceCapability node, and registered the DXA Model Service using Discovery Registration tool the service worked without any issue.

DXA Model Service is not registered error

The above error occurred due to Invalid OAuth Credentials in DXA Application Web.config.

Thank you, Rick, Velumurgan, and Bart for help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.