6

I'm working on an ECL integration for Web 8.5 right now. My plan is to resolve the ECL components with my own TBB. However, I cannot even publish a page using the default DXA TBB.

"Generate Dynamic Page (DXA)" throws an error when trying to resolve my ECL component.

ComponentBuilder: start BuildComponent with component ecl:0-cel-226-cea-file (tcm:1262-422810) and link level 49
EclProcessor: Retrieving ECL item for ECL Stub Component: tcm:1262-422810
ECL item 'ecl:1262-cel-226-cea-file' not found (TCM URI: 'tcm:1262-422810')
   at DD4T.Templates.Base.Utils.EclProcessor.GetEclItem(String eclStubComponentId, IContentLibraryContext& eclContext)

Am I missing something here?

Page Template contains:

 - Generate Dynamic Page (DXA)
 - Resolve Rich Text

Component Template for this component contains:

- Resolve ECL items V2
- Generate Dynamic Component (DXA)
- Publish binaries for component
- Resolve Rich Text

I can open the TCM-ID and the ECL-ID in the CMS, they both exist.

Thanks

Kind regards

Arne

  • Welcome to Tridion Stack Exchange, looks like this item tcm:1262-422810 does not exist in cms, double check that ECL item in that component linked it exists or not try to open that item to see? please edit your question to update what are the TBBs added in your component template and page template, is that ECL folder displays correctly on your pages level publication is it working as expected? – Velmurugan May 30 '18 at 9:10
  • Thanks for your answer, i can open the TCM-ID /WebUI/item.aspx?tcm=16#id=tcm:1262-422810 and the ECL-ID /WebUI/item.aspx?ecl=file#id=ecl:1262-cel-226-cea-file in Tridion. They both exists and look fine. The ECL folder also looks fine in the publication. – Arne May 30 '18 at 9:22
  • please edit your question to specify what is your DXA version? – Velmurugan May 30 '18 at 9:27
  • Done, its 1.8.. – Arne May 30 '18 at 9:30
  • 1
    Link Level 49 ?! Is that really needed? – Rick Pannekoek May 30 '18 at 20:21
3

It looks like you have not added Resolve ECL items V2 to your Component Template TBB.

In the template builder folder, you can see SDL External Content Library and named Resolve ECL items V2. Add this to your Component Template and it will deal with the ECL item.

I hope it helps.

  • ECL was installed with Web 8.5 but there is no "SDL External Content Library" folder in the template builder. – Arne May 30 '18 at 11:31
  • Ok sorry, i needed to create the default TBBs in the Template Builder, will add the V2 TBB now.. – Arne May 30 '18 at 11:52
  • 2
    Ok i needed to restart the template builder, error is actually resolved. Thank you. – Arne May 30 '18 at 12:30
  • 2
    If all is well, the “Resolve ECL items V2” TBB should not be required for DXA; you can see in the error message that DD4T templates will resolve links to ECL Stub Components anyways. I don’t know why you got that error, though. Can you check if it re-occurs if you remove the “Resolve ECL items” TBB again? – Rick Pannekoek May 30 '18 at 20:20
  • 1
    Also check out Jonathan’s Answer; it can explain why things all of the sudden start working (and later magically break again). – Rick Pannekoek May 30 '18 at 20:25
7

If your Publisher is outscaled onto a separate Windows server, then you'll need to make sure that the ECL mountpoints are configured correctly on that server too.

I've been caught-out by that before!

P.S. You'll need to restart the SDL Publisher Windows Service after making the change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.