12

I am struggling to get Tridion UI 2012 Session Preview working on a DD4T website. I view the website in a browser, click the SDL Tridion logo to enter 'edit' mode, then start editing some content on the page.

Once I edit something and click "Finish editing", the error is displayed in the browser: "An existing connection was closed by the remote host", and the webpage does NOT display the text you just edited. Then when I look at the log file for the Session Preview web service, I see the error "Maximum request length exceeded" - I did this by viewing the svclog file (produced by the Session Preview web service) in the ServiceTraceViewer tool.

Now, I have increased the request-size in the web.config of the Session Preview web service, but I still receive the same error. It seems that I need to make the same change (i.e. increase request-size) to the "consumer" of the Session Preview web service.

What is the consumer of the Session Preview web service? i.e. exactly which config file (.config, .xml , .jar, etc) contains a binding to the Session Preview web service? I need to find this file and increase the request-length in there, as a first step, I think.

It seems that the edit is saved to the Tridion_cm database because F5 shows the edit but the preview does not seem to update without a full refresh.

Also, I have already followed the following blog post (and satisfied all its steps/checks) for our debugging: http://albertromkes.com/2013/01/24/troubleshooting-the-sdl-tridion-experience-manager-with-session-preview/

Any ideas?

  • With that error message I suspect this is related to network / request length as you've mentioned in your post. - could you do some tweaking and see if this fixes the issue? – johnwinter Mar 1 '13 at 18:24
  • Just to be sure: Did you update the <binding> and the corresponding <service> tag in the web.config from the ODATA webservice? (Did you adjust the 'maxReceivedMessageSize' AND the 'maxBufferSize'?. See the 'AdustedBindingConfiguration' in my example.) – Albert Romkes Mar 4 '13 at 11:51
6

+1 to John's point and your initial troubleshooting approach.

Try adjusting the Web.config of the Session Preview (OData) webservice again--maybe double it until it works and/or confirm how much content (and maybe multimedia) is used by that page. Or try a smaller page. :-)

This StackOverflow post points out two settings, one for ASP.NET and another for IIS 7; multiple users also point out the difference in measurement unit (KB for .NET, but bytes for the IIS setting).

http://msdn.microsoft.com/en-us/library/e1f13641(v=vs.100).aspx

<configuration>
    <system.web>
        <httpRuntime maxRequestLength="size-in-KB" />
    </system.web>
</configuration>

But also:

http://msdn.microsoft.com/en-us/library/ms689462%28VS.90%29.aspx

<system.webServer>
   <security>
      <requestFiltering>
         <requestLimits maxAllowedContentLength="size-in-bytes" />
      </requestFiltering>
   </security>
</system.webServer>

Maybe someone else can fill in the details of what gets sent to Session Preview storage. I'm guessing it's the session-specific page, component presentations, and multimedia but haven't checked to be sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.