2

I need to make HTTPS call to core service which is provided by wsHttp binding. But my .net code is returning following error:

There was no endpoint listening at https:///webservices/CoreService2011.svc/wsHttp that could accept the message

Also when i tried to open the wsHttp binding URL from browser it is returning me Error 404.

Please provide me the config settings that I need to take care from my CMS server to consume wsHttp binding. Also we are using LDAP authentication.

My server side web.config for wsHttpBinding:

<wsHttpBinding>
    <binding name="CoreService_wsHttpBinding" transactionFlow="true" maxReceivedMessageSize="10485760">
      <readerQuotas maxStringContentLength="10485760" maxArrayLength="10485760" />
      <security mode="TransportWithMessageCredential">
        <message clientCredentialType="UserName" />
      </security>       
    </binding>
  </wsHttpBinding>

and

<endpoint address="wsHttp" binding="wsHttpBinding" bindingConfiguration="CoreService_wsHttpBinding" name="wsHttp" bindingNamespace="http://www.sdltridion.com/ContentManager/CoreService/2011" contract="Tridion.ContentManager.CoreService.ISessionAwareCoreService2011">
      <identity>
        <dns value="localhost" />
      </identity>
    </endpoint>

and client side is :

<wsHttpBinding>
    <binding name="wsHttp" closeTimeout="00:01:00" openTimeout="00:01:00"
      receiveTimeout="00:10:00" sendTimeout="00:01:00" bypassProxyOnLocal="false"
      transactionFlow="true" hostNameComparisonMode="StrongWildcard"
      maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text"
      textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false">
      <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
        maxBytesPerRead="4096" maxNameTableCharCount="16384" />
      <reliableSession ordered="true" inactivityTimeout="00:10:00"
        enabled="false" />
      <security mode="TransportWithMessageCredential">
        <transport realm="" />
        <message clientCredentialType="UserName" negotiateServiceCredential="true"
          algorithmSuite="Default" />
      </security>
    </binding>
  </wsHttpBinding>
  • Can you post your server webservices\Web.config and client web config, especially part related to wsHttp endpoint? – Andrey Marchuk Jun 21 '13 at 8:29
  • Is your core-service enabled on HTTPS; may be you simply put the URL - https:///webservices/CoreService2011.svc - in your browser and see if it opens correctly. If it does, then please share the snipette of your web.config for Core Service from the CMS server and ensure it is compatible with the one you are using at the client end. – Pankaj Gaur Jun 21 '13 at 8:41
  • Yes I am able to open the webservice on https. Also attached the snippet of my web.config in the question itself. – user552 Jun 24 '13 at 5:53
5

Have you followed the instructions to enable HTTPS for the CoreService, as documented in LiveContent? (login required)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.