2

We recently upgraded an environment to Web 8.5 from Tridion 2013. During the upgrade, we set up the new CD environment and upgraded the Web apps to use the new CIL (Restful API).

We did not have XPM setup in Tridion 2013 but with the move to 8.5, we decided to add XPM to the solution. We followed the documentation (https://docs.sdl.com/LiveContent/content/en-US/SDL%20Web-v5/GUID-CDBFB30A-AE02-4379-8C53-AFCF32B80FFD), however, after adding the "Enable Inline Editing for Page" TBB to the page template just beneath the DWT, we found that nothing was changed in the output. We tested template builder, the Web 8.5 Preview, and the published pages but the expected "SiteEdit" script tag does not appear on any of them. We tried adding a "SiteEdit Editor URL" to the template parameter but that did not help either.

Here is what we have tried:

We have setup the preview service and registered it with the discovery service. After doing so, we tested it and we were able to hit the preview URL so it appears to be correct.

We ensured that the "Enable for inline editing:" checkbox is checked for the page template and the component templates and that these templates are checked in.

Additionally, we ran the "Create Default Building Blocks..." tool from Template Builder Web 8.5 and updated all of the default building blocks. After that, we ensured the latest building blocks were in use in our templates but that did not help either.

We also tried adding <!--SITE_EDIT_INIT--> to the bottom of the page template just in case.

After doing all of this it appears as though the "Enable Inline Editing for Page" TBB is still not modifying the package's Output item. There are also no logs related to XPM appearing in Template Builder's Output view when I run the template against a page.

Is there anything we have missed that is required for this TBB to write the script tag into the package's Output item?

Edit with More Information:

The CME/publisher is not scaled out, both are installed on the same machine and only that machine. When I run the SDLWeb85CM.exe installer I can see that XPM is installed. Additionally, I have two entries in my Tridion.ContentManager.config file that relate to "SiteEdit":

<defaultTemplatesScripts>
    ...
    <defaultTemplatesScript scriptFile="SetupSiteEdit2012Templates.xml" />
    ...
</defaultTemplatesScripts>

and

<extensions>
    <add assemblyFileName="D:\Tridion\bin\Tridion.Web.UI.CME.TcmExtensions.dll" />
    <add assemblyFileName="C:\Program Files (x86)\SDL Web\bin\Tridion.SiteEdit.TcmExtensions.dll"/>
    ...
</extensions

I also found that SetupSiteEdit2012Templates.xml points to the "Tridion.SiteEdit.Templating.dll" file located in the bin directory of the CMS install. The "Tridion.SiteEdit.Templating.dll" file is located in the bin as well. In addition, there is also a Tridion.SiteEdit.TcmExtensions.dll located in the bin folder, but it is not mentioned in the SetupSiteEdit2012Templates.xml file.

Note that I double checked and has no spaces.

Edit: Adding a bit more information. It appears as though the "Enable Inline Editing For Content" TBB is not doing anything when used on components either. The TCDL tags are being added into the output from the DWT but they are not changed into comments by the "Enable Enline Editing For Content" TBB. Instead, they are left as TCDL tags and then cleaned up by the default finish actions.

The problem now appears to be very similar to this one: Why are my TCDL Tags not converted to XPM markup? Except that I have tried running the Template Builder update (which runs successfully), and I tried uploading the bin/Tridion.SiteEdit.Templating.dll over-top of the old one but neither method worked. I also ensured that there were no other Tridion.SiteEdit.Templating TBBs in the CMS and that the one I am using is not localized. I also double checked that the "Enable inline editing" TBBs both point directly to the correct Tridion.SiteEdit.Templating TBB.

Edit #2: I have created a very simple page template Which contains the following TBBS:

Home Layout (DWT)
Enable inline editing for Page (Default TBB) Default
Finish Actions (Default TBB)

Even with this simple Page Template the output is still unchanged by the "Enable inline editing for Page" TBB.

  • Where are you getting the XPM TBBs from exactly, did you have them added/updated by the new Web 8.5 Template Builder? Please edit your question and provide a bit more detail. – Bart Koopman Jun 8 '18 at 7:13
  • If your CME / Publisher is out scaled make sure all the servers installed Experience Manager site edit extensions installed verify in Tridion.ContentManager.config? – Velmurugan Jun 8 '18 at 7:14
  • @BartKoopman We have created/updated the latest TBBs from the Web 8.5 Template Builder yes. The information is in the question :) – Nicholas Wetmore Jun 8 '18 at 13:05
  • @Velmurugan I've updated my question to include the information. – Nicholas Wetmore Jun 8 '18 at 13:05
  • What about this Tridion.SiteEdit.TcmExtensions.dll?? also double check <!--SITE_EDIT_INIT--> should be no spaces? – Velmurugan Jun 8 '18 at 13:12
3

To summarize the issue and fix:

The default [Publication]\Building Blocks\Default Templates\Tridion.SiteEdit.Templating (TBB) C# Assembly Template broken.

It seems that the template builder upgrade process does not upgrade the Tridion.SiteEdit.Templating TBB (DLL) - this is needed for the XPM tags to be rendered for both CT and PT. To manually fix this TBB by uploading the DLL (which can be found in [Tridion-Home]\bin\Tridion.SiteEdit.Templating.dll)

Note:

In the template builder or CME page preview, XPM tags will not be rendered. Indeed because it will only resolve during the rendering and publishing context, To test the XPM tag output you need to be published to verify.

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.