5

On our CD environments we have a Deployer and a Deployer Worker Service all running on Windows Server 2012 R2. We are running Web 8.5 with latest Hotfixes.

When restarting the Deployer Worker Windows service, it sometimes fails to startup with an exception:

2018-06-11 10:07:16,951 ERROR ModuleFactory - Unable to create module
com.tridion.configuration.ConfigurationException: Unable to load Module
    at com.tridion.deployer.ModuleFactory.createModule(ModuleFactory.java:115)
    at com.tridion.deployer.ModuleFactory.createModuleOnPreference(ModuleFactory.java:72)
    at com.sdl.delivery.deployer.steps.TridionDeployerStepAdapter.configure(TridionDeployerStepAdapter.java:59)
    at com.sdl.delivery.deployer.steps.TridionExecutableStepFactory.processConfiguration(TridionExecutableStepFactory.java:169)
    at com.sdl.delivery.deployer.steps.TridionExecutableStepFactory.create(TridionExecutableStepFactory.java:140)
    at com.sdl.delivery.deployer.engine.step.BasicExecutableStepFactoryManager.getStep(BasicExecutableStepFactoryManager.java:44)
    at com.sdl.delivery.deployer.engine.pipeline.actor.StepActor.com$sdl$delivery$deployer$engine$pipeline$actor$StepActor$$execute(StepActor.scala:53)
    at com.sdl.delivery.deployer.engine.pipeline.actor.StepActor$$anonfun$receive$1.applyOrElse(StepActor.scala:44)
    at akka.actor.Actor$class.aroundReceive(Actor.scala:480)
    at com.sdl.delivery.deployer.engine.pipeline.actor.StepActor.aroundReceive(StepActor.scala:27)
    at akka.actor.ActorCell.receiveMessage(ActorCell.scala:526)
    at akka.actor.ActorCell.invoke(ActorCell.scala:495)
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:257)
    at akka.dispatch.Mailbox.run(Mailbox.scala:224)
    at akka.dispatch.Mailbox.exec(Mailbox.scala:234)
    at scala.concurrent.forkjoin.ForkJoinTask.doExec(ForkJoinTask.java:260)
    at scala.concurrent.forkjoin.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1339)
    at scala.concurrent.forkjoin.ForkJoinPool.runWorker(ForkJoinPool.java:1979)
    at scala.concurrent.forkjoin.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:107)
Caused by: com.tridion.util.TridionReflectionException: Unable to load request class, was not found on classpath
    at com.tridion.util.ReflectionUtil.loadClassInstanceWithTypes(ReflectionUtil.java:65)
    at com.tridion.deployer.ModuleFactory.createModule(ModuleFactory.java:109)
    ... 18 common frames omitted
Caused by: java.lang.ClassNotFoundException: 
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at com.tridion.util.ReflectionUtil.loadClassInstanceWithTypes(ReflectionUtil.java:59)
    ... 19 common frames omitted

This particular behavior happens ~ 0-1 time out of 5 restarts causing all deployments to fail. Usually the service starts normal without errors and is also working like expected. This cant be reproduces 100% as it appears random.

Did anyone have the same problem already and knows a fix for this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.