2

When I installing SDL Web8.5 by using the installer, following error occurs during installing Topology Manager.

A new member could not be added to a local group because of the member has the wrong account type.

The CMS Server is belonging to Active Directory domain, and the CMS server itself is a Domain Controller. Is it possible this fact is affecting? And how can I avoid this error?

The more detailed log message is following.

SFXCA: Extracting custom action to temporary directory: C:\Windows\Installer\MSI62B.tmp-\ SFXCA: Binding to CLR version v4.0.30319 Calling custom action CommonCustomActions!CommonCustomActions.WindowsGroupCustomActions.CreateGroupExecute Begin CreateGroupExecute CreateGroup: Unable to find the group 'devcms01\Topology Manager Users'. Creating new... CreateGroup: Unable to find the group 'devcms01\Topology Manager Service Users'. Creating new... CreateGroup: Unable to find the group 'devcms01\Topology Manager Administrators'. Creating new... AddToGroup: Checking if User 'takt01' is a member of 'Topology Manager Administrators' AddToGroup: User 'takt01' is not member of 'Topology Manager Administrators'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Administrators" "takt01" /add' RunCmdToolToAddToGroup: result '0' AddToGroup: Checking if child group 'NETWORK SERVICE' is a member of 'Topology Manager Administrators' AddToGroup: Child group 'NETWORK SERVICE' is not member of 'Topology Manager Administrators'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Administrators" "NETWORK SERVICE" /add' Application return an exit code 2 with next error: System error 1388 occured.

A new member could not be added to a local group because the member has the wrong account type.

RunCmdToolToAddToGroup: result '2' AddToGroup: Checking if child group 'Administrators' is a member of 'Topology Manager Administrators' AddToGroup: Child group 'Administrators' is not member of 'Topology Manager Administrators'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Administrators" "Administrators" /add' Application return an exit code 2 with next error: System error 1388 occured.

A new member could not be added to a local group because the member has the wrong account type.

RunCmdToolToAddToGroup: result '2' AddToGroup: Checking if child group 'Users' is a member of 'Topology Manager Users' AddToGroup: Child group 'Users' is not member of 'Topology Manager Users'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Users" "Users" /add' Application return an exit code 2 with next error: System error 1388 occured.

A new member could not be added to a local group because the member has the wrong account type.

RunCmdToolToAddToGroup: result '2' AddToGroup: Checking if child group 'SYSTEM' is a member of 'Topology Manager Service Users' AddToGroup: Child group 'SYSTEM' is not member of 'Topology Manager Service Users'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Service Users" "SYSTEM" /add' Application return an exit code 2 with next error: System error 1388 occured.

A new member could not be added to a local group because the member has the wrong account type.

RunCmdToolToAddToGroup: result '2' AddToGroup: Checking if child group 'NETWORK SERVICE' is a member of 'Topology Manager Service Users' AddToGroup: Child group 'NETWORK SERVICE' is not member of 'Topology Manager Service Users'. Adding... Execute application 'net' with arguments 'localgroup "Topology Manager Service Users" "NETWORK SERVICE" /add' Application return an exit code 2 with next error: System error 1388 occured.

A new member could not be added to a local group because the member has the wrong account type.

  • Is that user which you trying to install is it has local admin rights on the machine? – Velmurugan Jun 14 '18 at 14:54
  • The user who does installation is Active Directory user, and it belongs to Administrators group which is buit-in Active Directory group. I started installer by 'Run as administrator'. Also CMS server itself joins in an AD's domain. Is it still necessary to use local administrator user to install? – Hirokazu Shikata Jun 15 '18 at 0:09
  • I have heard about installation issues when trying to install on a Domain Controller, indeed. In general, this is considered a bad practice. – Rick Pannekoek Jun 15 '18 at 6:30
  • I asked SDL support about this issue, they say it's impossible to install SDL Web into Domain Controller server, unfortunately. – Hirokazu Shikata Jun 15 '18 at 9:59
  • Please Answer your own Question, in that case. – Rick Pannekoek Jun 15 '18 at 13:30
3

I asked SDL support about this issue, they say it's impossible to install SDL Web into Domain Controller server, unfortunately.

  • Can you mark this as the correct answer please? – Jonathan Williams Oct 10 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.