0

I am seeing below error in model service log. And 404 received on the website for all pages. Let me know what I am missing in configuration.

2018-07-12 04:19:46,118 WARN c.s.d.m.s.p.e.PageModelExpander - Cannot expand entity EntityModelData(id=257-99, componentTemplate=null, linkUrl=null, content=null, binaryContent=null, externalContent=null) for page PageRequestDto(publicationId=5, uriType=tcm, path=/error-404, includePages=INCLUDE, contentType=MODEL, dataModelType=R2, expansionDepth=100, depthCounter=com.sdl.dxa.common.dto.DepthCounter@98) com.sdl.webapp.common.exceptions.DxaItemNotFoundException: Cannot find a CP for componentUri = tcm:5-257, template id = 99

Also, I see DXA settings in Admin screen greyed out.

  • Looks like something isn't published. – Neil Jul 12 '18 at 7:54
  • Welcome to Tridion StackExchange Ramana, You can try this question answer, it will help you to fix your issue, tridion.stackexchange.com/questions/18340/… – Velmurugan Jul 12 '18 at 7:59
  • The error message indeed, This component (tcm:5-257) is not published because of that model service not able to expand the entity, You can try publish that component keep check the error message to troubleshoot by enabling trace logs on model service, content service and web app then you should be able to fix this issue yourself. keep it posted. – Velmurugan Jul 12 '18 at 8:06
1

To fix the above issue try this question answer, it will help you to fix that issue.

In DXA 2.0 it has new feature DXA Resolver if you install this feature part of your DXA installation on the CMS server then, DXA Resolver to ensure these DCPs are automatically republished, if not installed then it's mandatory to publish those used DCP components in order to expand the Entity in the model service.

For using Static Navigation, Indeed documentation not mentioned to publishing the [Navigation] Categories and Keywords. I have left the comment in the documentation.

I hope it helps.

  • DXA Resolver was already installed. Even then the only solution worked was publishing DCPs. – Ramana Venkata Jul 13 '18 at 3:28
0

Its mandatory to publish component templates and keywords. Seems not in the documentation. It worked after publishing both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.