How to autopublish pages and components in Powershell module in Tridion 2013? I want to publish contents in automated way in Tridion 2013 SP1

  • 1
    Please improve this Question. It is lacking a lot of details. You have already provided a lot more information as Comments to Sayantan’s Answer, but please update the Question (too) to be more specific as to what you tried and what the problem is you are encountering. Aug 3 '18 at 19:59

Have you tried anything yet, then please update you question with details ?

For your information yes, it is possible to publish items with Tridion Powershell Module. You can use below command to publish items -

Publish-TridionItem -Id 'tcm:1-59' -TargetId 'tcm:0-1-65537' -Priority High

For more details you can check this link.

  • Yes, I have tried Powershell module and tried to run the script after registering/adding all the required DLL's,.ps1 files etc in the folder. Created a task scheduler to run the script and it is not working. I can paste the script too
    – user1849
    Aug 3 '18 at 11:03
  • 1
    Yes. Please update your script in the question. Also verify the coreservice setting. I mean r u able to access your cme using that powershell module ? Aug 3 '18 at 11:37
  • This command : Publish-TridionItem -Id 'tcm:1-59' -TargetId 'tcm:0-1-65537' -Priority High: This is also not working. Getting an error:Exception calling "Publish" with "5" argument(s): "There was no endpoint listening at http//crassdl13dev01/SDL/webservices/CoreService2013.svc/wsHttp that could accept the message.
    – user1849
    Aug 3 '18 at 12:23
  • That means your coreservice connection is not working. You can check the process to set up coreservice -> github.com/pkjaer/tridion-powershell-modules/wiki/…. I will suggest you to check BesicHTTP as well. Aug 3 '18 at 12:46
  • The coreservice URL: cms.server.com/webservices/CoreService2013.svc/wsHttp is not working .The host name resolution (DNS lookup) for this host name ( cms.server.com ) has failed. The Internet address may be misspelled or obsolete, the host ( cms.server.com ) may be temporarily unavailable, or the DNS server may be unresponsive.
    – user1849
    Aug 3 '18 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.