1

I have a project using DXA 2.0 I need to add some SSRS reports so used this solution : https://code.msdn.microsoft.com/How-to-Display-SSRS-report-e3f6be05 Basically, its embeds ASPX form in IFRAME and it works fine but some reports have links, when I click the link I got an internal exception:

ERROR [Sdl.Web.Delivery.ADF.AmbientRuntime.OnRequestStart] - Setting status code:500 ERROR [Sdl.Web.Delivery.ADF.AmbientRuntime.OnRequestEnd] An error occured while the request was processed. OnRequestEnd will not be triggered! The thread 0x380c has exited with code 0 (0x0). The thread 0x58e4 has exited with code 0 (0x0). The thread 0xce4 has exited with code 0 (0x0). The thread 0x6edc has exited with code 0 (0x0). The thread 0x6ccc has exited with code 0 (0x0). 2018-10-12 13:22:44 ERROR [Sdl.Web.Delivery.ADF.AmbientRuntime.OnRequestStart] - Problem EXCEPTION: System.ArgumentNullException: Value cannot be null. Parameter name: key at System.Collections.Generic.Dictionary2.FindEntry(TKey key) at System.Collections.Generic.Dictionary2.ContainsKey(TKey key) at Sdl.Web.Delivery.ADF.AmbientRuntime.SetWebRequestClaims(HttpRequest request, IClaimStore claimStore) at Sdl.Web.Delivery.ADF.AmbientRuntime.OnRequestStart(HttpApplication application, HttpContext context, IClaimStore claimStore, ISet1 templateReadOnlyClaims, ISet1 templateImmutableClaims, ISet`1 templateSessionScopeClaims, Boolean dispatchOdataRequest)

Any ideas?

the headers of the request that causes the issue:

POST http://localhost:55507/ReportViewerWebForm.aspx HTTP/1.1 Host: localhost:55507 Connection: keep-alive Content-Length: 17325 Origin: http://localhost:55507 X-Requested-With: XMLHttpRequest Cache-Control: no-cache X-MicrosoftAjax: Delta=true User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36 Content-Type: application/x-www-form-urlencoded; charset=UTF-8 Accept: / Referer: http://localhost:55507/ReportViewerWebForm.aspx Accept-Encoding: gzip, deflate, br Accept-Language: en-US,en;q=0.9,ar;q=0.8 Cookie: .........

ScriptManager1=ScriptManager1%7CReportViewer1%24ctl13%24ReportControl &__EVENTTARGET=ReportViewer1%24ctl13%24ReportControl &__EVENTARGUMENT= &__LASTFOCUS= &__VIEWSTATE=...... &__VIEWSTATEGENERATOR=4C160F9C &__EVENTVALIDATION=........ &__ASYNCPOST=true& &__EVENTTARGET=ReportViewer1%24ctl13%24ReportControl &__EVENTARGUMENT= &__LASTFOCUS= &__VIEWSTATE=...... &__VIEWSTATEGENERATOR=4C160F9C &__EVENTVALIDATION=........ &__ASYNCPOST=true&

  • How does the HTTP request which causes this error look? – Rick Pannekoek Oct 16 '18 at 17:30
  • Updated the the post – Mohammed Alhanooti Oct 17 '18 at 16:43
  • I don’t see any obvious problem in the request. Please contact SDL Customer Support (this seems to be an issue with the ADF). – Rick Pannekoek Oct 19 '18 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.