I need a small help with core service related issue: So I got a Tridion Web 8.5 Core Service Wrapper (A WCF service) and a Sample .NET application (a simple ASPX page) testing various methods of it on wsHttp binding. so here is what I got:

  1. I run the WCF service and .NET app on my local machine; WCF service is pointing to Tridion on Server X - It works as expected
  2. I put the WCF service on a Server Y and keep the .NET app on my local machine; WCF service is still pointing to Tridion on Server X - It works as expected
  3. I put the WCF service on Server X, .NET app on my local machine; WCF service points to the Tridion on Server X - IT DOES NOT WORK
  4. I put .NET App, WCF service on Server X along with Tridion; WCF service points to the Tridion on it - IT ALSO DOES NOT WORK

The error I am getting is:

The request for security token could not be satisfied because authentication failed

Inner Exception:

SecurityNegotiationException: The caller was not authenticated by the service

Debugging shows this is happening while creating SessionAwareCoreService client using Channel Factory - the Client created successfully, but when try to "Open" the client or perform any core service call, the exception occur

Following is what all I have tried (but did not work):

  1. Double checked the network credentials are been passed and are correct while creating the core service client (the same is working when WCF service is deployed somewhere else)
  2. Tried localhost references to Tridion, WCF service etc.
  3. Tried HTTPS with a valid SSL certificate
  4. Tried with host headers for .NET app and WCF service with same DNS
  5. Tried different Security Modes while creating client including "None"
  6. Ensure browser internet security is at "Medium"

I don't want to run it on "net.tcp". any help or thought is appreciated

  • Set security to "None" in the wsHttpBinding give a try it may help you – k951 Oct 31 at 5:02
  • Thanks. Kindly refer point number 5 above in what I have tried. I already tried it in the code as well as Core Service config – Pankaj Gaur Oct 31 at 7:31
  • 1
    I'm not sure, It could be something to do with loopback. because you are saying this problem only happens if you are running your WCF service and Tridion on the same server host. enable full trace on your WCF service share the logs? did you try to test with some simple core service code on the server? or maybe worth try to install the peter PowerShell core service module try to test first? – Velmurugan Oct 31 at 8:45
  • CME server is running on http or https? Is there any SSO enabled? Is there any antivirus or firewall software installed? – Velmurugan Oct 31 at 8:47
  • Hi Velmurugan...thanks for the inputs....I did the registry setting for Loopback and waiting for off business hours to restart the server - as that setting will only take effect after server reboot - its acceptance server. SSO: Yes there is SSO out there Powershell/Simple Core Service App: I tried with a console app and same error. Can't install powershell module Firewall etc. - Tried after disabling – Pankaj Gaur Oct 31 at 14:23

OK, so it turned out to be the Loopback issue (thanks to Velmurugan and Harald for the pointers).

Here is the details about the Loopback issue: MSDN Blog

You can choose to apply various suggestions made over there - kindly take note of security loopholes it might bring

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.