Does anybody knows what happens with Tridion Sites 9 and DXA 2.0? I think I have all the configuration files and settings ok, but I am not able to make it work.

Is there any known issues? Any workaround?

DXA 2.1 .Net will support Tridion Sites 9 and is planned to be released in the coming days.

  • 1
    DXA.NET 2.1 has been released now. Unfortunately, for Java Web Applications, you will have to await DXA 2.2 to benefit from the new features. However, DXA Java 2.0 will run fine on Tridion Sites 9.0 / DXD 11.0. – Rick Pannekoek Dec 5 at 18:47

Quick Fix: SWitch off the Custom Resolver (the one that controls the link depth resolving).

It's not formally supported but will be in DXA 2.1 as far as I know.

There is another issue with the context services (explained in the blog post by Hem noted above).

update - per Rick's comment below:

There is more clarity on the reported issue with DXA Resolver UI Extension: it works fine with Sites 9 as long as you don't install it in the WebUI folder. The default location (configured in cms-import.ps1) works fine

  • 1
    The problem with the 9.0 Context Service is that it is more strict regarding URL encoding (because of a Tomcat upgrade) and hence not compatible wirh CIL 10.1. This is fixed in CIL 11.0 (which DXA 2.1 will use). – Rick Pannekoek Nov 16 at 8:36
  • 1
    In the meantime, you can try to build DXA 2.0 against CIL 11.0 or configure AdfContextClaimsProvider instead of ContextServiceClaimsProvider (in Unity.config). This effectively disables Context Engine functionality, but at least you Web App will run. – Rick Pannekoek Nov 16 at 11:58
  • As @RickPannekoek mentioned we need to disable the context service dependency to run DXA 2.0 with Tridion Sites 9, that's all I did in order to make DXA 2.0 works with Tridion 9 – Hem Kant Nov 21 at 11:33
  • 1
    There is more clarity on the reported issue with DXA Resolver UI Extension: it works fine with Sites 9 as long as you don't install it in the WebUI folder. The default location (configured in cms-import.ps1) works fine. – Rick Pannekoek Nov 22 at 8:25

DXA 2.1 is out, but it's only compatible with Sites 9 (as far as Tridion is concerned). Compatibility overview here

  • The main reason for DXA 2.1 release was to leverage/showcase the new features in Tridion Sites 9.0 / DXD 11.0. However, compatibility with SDL Web 8(.5) will be re-introduced in DXA 2.2 (together with Java Web App support). – Rick Pannekoek Dec 5 at 18:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.