2

I am trying to upgrade Deployer extension code from Tridion 2013 to SDL Web 8.5. I am not sure what all Java apis need to be upgraded, I tried with deployer-api-8.5.0-1013.jar but not able to resolve some classes and getting compilation errors, i.e.

import com.tridion.configuration.Configuration;
import com.tridion.configuration.ConfigurationException;
import com.tridion.deployer.Module;
import com.tridion.transport.transportpackage.TransportPackage;

Please help me to figure out what api i should add to Maven dependency.

Thanks

1

Try to upgrade your deployer extension project with following 8.5 deployer jars dependencies to work for SDL Web 8.5

  • cd_common_config-8.5.0-1009.jar
  • cd_common_config_legacy-8.5.0-1009.jar
  • cd_common_util-8.5.0-1009.jar
  • cd_core-8.5.0-1011.jar
  • cd_datalayer-8.5.0-1014.jar
  • cd_datalayer_extension-8.5.0-1014.jar
  • cd_model-8.5.0-1013.jar
  • cd_tcdl-8.5.0-1014.jar
  • commons-codec-1.10.jar
  • deployer-model-8.5.0-1014.jar
  • deployer-web-extension-8.5.0-1013.jar
  • httpclient-4.5.2.jar
  • httpcore-4.4.5.jar
  • jackson-core-asl-1.9.4.jar
  • jackson-mapper-asl-1.9.13.jar
  • jcl-over-slf4j-1.7.12.jar
  • logback-classic-1.1.7.jar
  • logback-core-1.1.7.jar
  • slf4j-api-1.7.12.jar

I hope it helps.

  • Hi @Velu, Thanks for the answer, i'll check with mentioned jars and let you know – Neetesh Narvaria Nov 29 '18 at 6:24
  • Adding Jars fixed compilation issue, thanks for information. – Neetesh Narvaria Nov 29 '18 at 11:33
2

It depends which classes you use in your code, for example, my Deployer extension (custom Module) is working with the dependencies listed below.

Just another point, in Tridion 2013 (SP1) you could create custom Processors, but they are no longer supported. Meaning, that if your old code has any, you will need to change the logic for Web 8.5, you cannot simply rebuild your code against the new jars.

<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>cd-core</artifactId>
    <version>8.5.0</version>
</dependency>
<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>cd-common-util</artifactId>
    <version>8.5.0</version>
</dependency>
<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>cd-common-config-legacy</artifactId>
    <version>8.5.0</version>
</dependency>
<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>deployer-web-extension</artifactId>
    <version>8.5.0</version>
</dependency>
<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>deployer-api</artifactId>
    <version>8.5.0</version>
</dependency>
<dependency>
    <groupId>com.sdl</groupId>
    <artifactId>cd-model</artifactId>
    <version>8.5</version>
</dependency>                
<dependency>
    <groupId>org.slf4j</groupId>
    <artifactId>slf4j-log4j12</artifactId>
    <version>1.6.6</version>
</dependency>
  • Hi @Atila, Thanks for answer and suggestion on Processor, will check if there is any custom processor. – Neetesh Narvaria Nov 29 '18 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.