2

One of the user in our Tridion CME is not able to Access the "SDL Media Manager" Folder. While accessing the Particular section getting the below error Message.

**Unable to get the list of items
Object reference not set to an instance of an object.**

 at Tridion.ExternalContentLibrary.UI.Model.Services.GeneralImpl.GetList(String id, Int32 pageIndex, Filter filter, Int32 columns)
   at Tridion.ExternalContentLibrary.UI.Model.Services.General.GetList(String id, Int32 pageIndex, Filter filter, Int32 columns)
   at SyncInvokeGetList(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   at Tridion.Web.UI.Core.Extensibility.DataExtenderOperationInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

We have cloned the user access Privileges with the other user which he is able to access the same SDL Media Manager Folder, even after that we are getting same error. One more thing when ever the user is trying to open any Component which is used Media Manager files he is not able to access.

Could you please provide an assistance to resolve the issue.

  • Could be a chance that user may exist 2 users on MM with domain and without domain double check? SDL Tridion Sites will auto-create the user which you need to identify the right user to clone? – Velmurugan Jan 29 at 8:51
  • @Velmurugan,Thanks for your response. We have verified the user list in Media Manager we do have two media manager accounts with and without Domain. we have cloned the user with the user which he is able to access the media manager stuff in Tridion CME. Still we are facing same issue. – Sree G Jan 29 at 13:03
  • @Velmurugan, we found the issue. The issue is related to special character symbool present in his E-mail ID. Even when we save the Media manager account manually it throwed an error saying that invalid E-mail id. We have asked customer to provide email id without special characters. Post that we have attached the provided id in AD which is attached with Tridion user account. Now he is able to access the SDL Media manager stuff. – Sree G Jan 31 at 22:37
  • 1
    Good to know you fixed your issue. Please self answer to your question, so that its resolved and this question can be closed – Velmurugan Feb 3 at 15:21
0

The issue is related to special character symbol present in his E-mail ID. Even when we save the Media manager account manually it throwed an error saying that invalid E-mail id. We have asked customer to provide email id without special characters. Post that we have attached the provided id in AD which is attached with Tridion user account. Now he is able to access the SDL Media manager stuff.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.