In Tridion 2013 SP1, there was an attribute called WindowSize in the cd_deployer_conf.xml file. If you set the value of the WindowSize attribute to 1 and publish a large number of Pages or Components, only one Publish Transaction will be waiting for deployment, all others will be throttled. In addition, only one transport package is placed in the incoming directory on the Content Delivery side.

In Web 8.5, the WindowSize attribute has been removed from the deployer_conf.xml file. When publishing a large number of pages and components, a large number of (hundreds of) publish transactions will be "waiting for deployment" and a large number of transport packages will be placed in the incoming directory on the Content Delivery side. As a result, queries to obtain publish status are executed in large quantities, the load on the database suddenly increases, the deployment process is further delayed, eventually the publishing process is stuck.

Why was the WindowSize attribute deleted in Web 8.5?

And how do you finally solve the publish stuck by causing many publish transactions in the "waiting for deployment" state?

We found troubleshooting content in the SDL Web 8.5 manual, but it did not help us.

1 Answer 1


Content Manager

Increase polling in the transport configuration file, (CMS)\SDL Web\config\cd_transport_conf.xml

For instance, this is the default entry and the numbers may need to be raised via a tuning exercise.

<!-- Specifies the polling attempts and timeout in minutes and interval between polls in milliseconds -->
<Polling MaxAttempts="900" Timeout="15" Interval="5000"/>

Restart the transport service for this change to take effect.

Content Delivery

In the deployer service application.properties file to increase the maximum size permitted for uploaded/allowed for files requests according to your maximum package size requirements



clean you incoming queue folder, restart deployer for these changes to take effect and publish again

  • Thank you for reply. Since this is not a matter of file size, it is a matter of the number of queues, so unfortunately I think that it will not be solved by setting spring.http.multipart.max-file-size you introduced. Do you know the settings like WindowsSize that limits the number of queues? Feb 1, 2019 at 6:23
  • Add debug on the publisher and deployer side in logback.xml paste stack trace in your question will help to find the exact issue
    – k951
    Feb 1, 2019 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.