3

I am getting the error below while running the PowerShell script.

enter image description here

The export is successful and the user is part of 'Topology Manager Administrators' windows group

Topology Instance and CD are both in the same server.

Also if I run like the below screenshot, the import is successful but when I hit the URL - http://localhost:81/ttm201501/$metadata#mappings I don't see any updated mapping data for cdEnvironment, Website, Webapplication etc.

enter image description here

  • 1
    As you already figured out yourself, the UpdateExistingItems parameter is a so-called flag parameter which you either specify (without value) or not. – Rick Pannekoek Feb 16 at 10:05
1

The PowerShell cmdlet syntax you use in your last example is correct.

However, the OData query you are using will not give you the TTM Mappings, but only (Schema) metadata about them. Try using the PowerShell cmdlets, for example: Get-TtmMapping, Get-TtmWebsite, Get-TtmWebApplication.

Furthermore, as far as I know, the Export/Import-TtmCdStructure cmdlets do not export/import TTM Mappings at all, but only the “structure” of a given CD Environment (i.e. Websites and Web Apps defined for that CD Environment).

Can you explain what you want to achieve?

  • 1
    Yes, if I run the Powershell scripts, I can see the mapping data. Everything looks fine and it gets published successfully to the Broker DB. But when I hit the Application URL, I get the below error: Page URL path '/navigation.json' in Publication '15' returned no data. Exception Details: Sdl.Web.Common.DxaException: Page URL path '/navigation.json' in Publication '15' returned no data. [DxaException: Page URL path '/navigation.json' in Publication '15' returned no data.] Sdl.Web.Tridion.Mapping.GraphQLContentProvider.GetPageContent(String urlPath, Localization localization) – Developer Feb 17 at 14:46
  • Ok, but that doesn't sound like a problem with your Topology Manager / Discovery Service: note that the Publication ID (15) has already been resolved. The problem is that you apparently don't have a Page with URL "/navigation.json" (in Publication 15) in your CD Content Store. Did you publish the "Navigation" Page? – Rick Pannekoek Feb 18 at 15:06
  • Yes, i published it and i can see in the DB too – Developer Feb 18 at 15:27
  • With that URL and Publication ID? Can you intercept the DB queries (e.g. with SQL Profiler) to understand what's going wrong? – Rick Pannekoek Feb 18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.