2

I'm testing the Sites 9 ElasticSearch functionality for Experience Optimization, as discussed in documentation link

Elasticsearch and Kibana 6.6.1 are installed on a remote machine, and I'm able to browse successfully to both services remotely on their respective default ports 9200 and 5601. No authentication configured. When I run the script "installElasticSearchIndexes.ps1 -es-host ES_HOSTNAME, I see below error from both the CM server and the ES server. Full error on Pastebin.

ERROR com.sdl.delivery.iq.provider.elastic.connector.bootstrap.BootstrappedElasticSearchConnector 
- PUT http://ES_HOSTNAME:9200/udp-index: HTTP/1.1 400 Bad Request {"error":{"root_cause":
[{"type":"mapper_parsing_exception","reason":"Failed to parse mapping [udp-content-default]: 
No field type matched on [float], possible values are [object, string, long, double, boolean, date, binary]"}],"type":"mapper_parsing_exception","reason":
...
ERROR com.sdl.delivery.iq.provider.elastic.connector.bootstrap.BootstrappedElasticSearchConnector 
- Either couldn't read file or connect to ElasticSearch. File:elasticsearch.json

On ES Windows server, JDK version on server is 1.8.0_201, %JAVA_HOME% env var is defined. I've scanned through the PS script and config files in the elasticsearch installation resources folder, don't see anything potentially troublesome. Any thoughts as to why the script is failing to execute?

4

I noticed in your installation error logs you have wrongly installed SDL Tridion Docs search functionality elasticsearch indexes installation script instead of XO elasticsearch installation script.

Note:

Documentation is indeed and it's correct but you have wrongly referred to the installation media folder for the script.

XO Installation script media folder: Content Delivery\roles\xo\resources\elasticsearch\

SDL Tridion Docs Search ES Installation script media folder: Content Delivery\resources\elasticsearch\

I can confirm that I did a test with Elasticsearch version 5.6 it's working fine.

The following below steps helps you to validate the installation

  1. Install Elasticsearch version 5.5 or 5.6
  2. Install the following Elasticsearch plugins from your elasticsearch installed bin folder.
     .\elasticsearch-plugin install ingest-attachment
     .\elasticsearch-plugin install analysis-icu
  1. Open a PowerShell command shell as Administrator and navigate to the installation media folder Content Delivery\roles\xo\resources\elasticsearch\.
  2. Run this command to install the xo indexes
    .\installElasticsearchIndexes.ps1 -es-host "localhost" -es-port 9201
        -es-scheme "http"

I hope it helps.

| improve this answer | |
  • Many thanks Velmurugan, confirming that index creation is successful when using the correct installation script, and also using a supported instead of unsupported version of Elasticsearch. – Terry Kim Mar 10 '19 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.