4

I am using Tridion for the first time, as I was requested to do some changes for a company.

I have never used this before, so I logged into the "backoffice" and tried updating the content for a specific Page which I found in "Content Management" section.

I see four groups in the first level of the tree (4 sites, different languages for what I can tell).

I edited the same page in the 4 available languages, checked in all of them but don't see them in the live site.

Just an update

For both the commenter and the answerer of my post, I did try publishing the items, and forgot to mention. This is a screenshot of the publishing queue, and as you can see, there is nothing pending publishing. Should I be looking somewhere else? https://snag.gy/VlmLbq.jpg

Update 2

I have just taken a screenshot of the process again. So first I checked-out the files, then I edited the files, and afterwards, without chinking in, I clicked on publish. I see 2 environments in the publish modal, I can see the files and I clicked publish: https://snag.gy/IukLqs.jpg

This is the result of publishing. As you can see, I tried publishing to 2 different sites (860 and 870) in 2 environments, preview and live. 870 says success, 860 says failed. same process, and no reflection of the changes in any of the sites (I am not sure exactly what 860 and 870 mean by the way). I am trying to do some changes to get my way around this, it's my first attempt to mess with tridion: https://snag.gy/ZIBUqL.jpg

** Update 3 **

Here are a few more screenshots with details of the error.

First screenshot is this: https://snag.gy/nZCLX5.jpg

And when I click the magnifying glass: https://snag.gy/9m6rgL.jpg

  • Hi BlunT, welcome to our communicty. You said you 'checked in all of them', but did you also publish te page? – Peter van der Lugt Mar 25 at 9:41
  • hi @PetervanderLugt thank you for that, but I did try to publish and the problem still remains. I updated the question to include that information. – BlunT Mar 25 at 20:19
  • The screenshot does not show the resulting publish transactions in the queue. Did you click the 'show tasks' button and are your filters correct? You need to verify whether that transaction reaches the success state. – Atila Sos Mar 26 at 11:57
  • @AtilaSos added some additional screenshots of the publishing step – BlunT Mar 26 at 20:51
  • 1
    @BlunT, Tridion can be quite complex and you are dealing with a publishing issue above. I highly recommend that you contact the specific IT team that is currently supporting the application within your organization. Atila's answer below should be a good starting point for you to start investigation. If you are tasked with supporting the application, you should contact SDL learning and probably get a training scheduled for you (sdl.com/trainings/sdl-tridion-sites.html). Cheers! – Shiva Apr 2 at 3:21
3

Hi BlunT and welcome to the club ;). Tridion is quite complex, so I'll try and simplify things as much as possible to help solve your issue, but also not to confuse you to much.

Tridion consists of two large systems the Content Manager (CM) (the editorial part of the system) and Content Delivery (CD) (the part of the system which serves content). Each of these has it's own data stores for various reasons, one of them being separation.

In order to have your updated content show up on your sites, you need to have those changes on the CD as well. This is done by an action called "publishing", in which content from the CM side is transformed, packaged and transported to the CD side, where it is processed and persisted. Having this in mind and your description of the issue, it is clear that you have not done this part. Your content is indeed updated on the CM side, but it is not yet available in CD.

Once you publish an item, it goes to the Publishing Queue which will hold information about the status of the resulting Publish Transaction. If it reaches the "success" state (you will need to refresh the list manually), then your updated items are persisted to the CD side.

A good place to grasp some information is the official documentation portal here

See also:

Publishing

How to publish a Page

Publishing Queue

If the publishing gets stuck or fails, the Publishing Diagram can help you.

And finally, since you've mentioned various languages, it would make sense to take a look at Blueprinting and try and understand how items are inherited.

  • Thank you for the hint, but I did already try to publish it more than once. I updated the question to include a screenshot of the publishing modal. Unless I am missing something, the problem must be somewhere else. – BlunT Mar 25 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.