4

I am setting up SDL Web 8.5 as a standalone on a single machine for learning and training purposes. Whilst installing and configuring SDL Web Content and DXA Model Service using DXA 2.0, unable to start the services.

Firstly, I am trying to configure the Content Service alone.

One thing to note if I run the service using the command line as using start.ps1 for windows m/c it runs successfully.

Checking the Event Viewer, I can see an inconclusive message:

The SDL Web Content Service service terminated with the following service-specific error: The system cannot open the file.

After detailed troubleshooting using Process Monitor and also starting procrun.exe Observed the following points:

  1. Ran Process Monitor for Path - C:\SDL\Web\content (Content Service Executable Path) and in return getting PATH NOT FOUND for a procrun.exe process. See below :

WinServiceContainer Class Path formed incorrectly

  • Secondly, I also checked C:\Windows\System32\LogFiles\Apache\commons-daemon.2019-03-27.log file See Details:

[2019-03-27 21:19:34] [info] [10556] Commons Daemon procrun (1.0.15.0 64-bit) started

[2019-03-27 21:19:34] [info]  [10556] Running 'SDLWebContentService' Service...

[2019-03-27 21:19:34] [info]  [ 5516] Starting service...

[2019-03-27 21:19:34] [error] [ 8348] FindClass com/sdl/delivery/service/WinServiceContainer failed

[2019-03-27 21:19:34] [error] [ 5516] Failed to start Java

[2019-03-27 21:19:34] [error] [ 5516] ServiceStart returned 4
  • I am unable to figure out what went wrong as I am trying to run the content service on 8081 port which is not being used by other service

  • I also checked the JAVA_HOME variable correctly being updated in ENVIRONMENT VARIABLES. Although, had to update it manually in system variables.

  • Also, checked the config files with all the key-value properties I am using is without $ env or jvm level resolution. Hence, assigning values directly in config files.

  • I have re-checked all the binary files are being unblocked.

  • I tried to implement the sugestion mentioned in one of the post - SDL Web Context Service not starting but not successful.

    Based, on the information I see an issue with internal JAVA Classpath WinServiceContainer not being found. Is it something related to configuration file?

Can anyone guide me and help me to resolve the issue. Hopefully, a similar resolution be applicable to DXA Model Service not being started.

UPDATE

Using 'Session Enabled Content Service' for DXA Staging Only Site. Thus, content service is installed and running as a windows service. But, when trying to install Model Service either on port 8080 or 8988 using installService.ps1. It fail to start. Getting below log set at DEBUG mode:

[2019-03-29 18:09:35] [debug] ( prunsrv.c:1679) [ 8784] Commons Daemon procrun log initialized
[2019-03-29 18:09:35] [info]  ( prunsrv.c:1683) [ 8784] Commons Daemon procrun (1.0.15.0 64-bit) started
[2019-03-29 18:09:35] [debug] ( prunsrv.c:561 ) [ 8784] Installing service...
[2019-03-29 18:09:35] [info]  ( prunsrv.c:600 ) [ 8784] Service SDLDXAModelServices name SDL DXA Model Services
[2019-03-29 18:09:35] [debug] ( prunsrv.c:616 ) [ 8784] Setting service description Content Delivery Micro Services For DXA
[2019-03-29 18:09:35] [info]  ( prunsrv.c:634 ) [ 8784] Service 'SDLDXAModelServices' installed
[2019-03-29 18:09:35] [info]  ( prunsrv.c:1764) [ 8784] Commons Daemon procrun finished
[2019-03-29 18:09:38] [debug] ( prunsrv.c:1679) [ 2592] Commons Daemon procrun log initialized
[2019-03-29 18:09:38] [info]  ( prunsrv.c:1683) [ 2592] Commons Daemon procrun (1.0.15.0 64-bit) started
[2019-03-29 18:09:38] [info]  ( prunsrv.c:1596) [ 2592] Running 'SDLDXAModelServices' Service...
[2019-03-29 18:09:38] [debug] ( prunsrv.c:1374) [10664] Inside ServiceMain...
[2019-03-29 18:09:38] [debug] ( prunsrv.c:844 ) [10664] reportServiceStatusE: 2, 0, 3000, 0
[2019-03-29 18:09:38] [info]  ( prunsrv.c:1127) [10664] Starting service...
[2019-03-29 18:09:38] [debug] ( javajni.c:233 ) [10664] loading jvm 'C:\Program Files\Java\jre1.8.0_202\bin\server\jvm.dll'
[2019-03-29 18:09:38] [debug] ( javajni.c:704 ) [ 8856] Jvm Option[0] exit
[2019-03-29 18:09:38] [error] ( javajni.c:863 ) [ 8856] FindClass com/sdl/delivery/service/WinServiceContainer failed
[2019-03-29 18:09:38] [debug] ( javajni.c:964 ) [ 8856] Java Worker thread finished com/sdl/delivery/service/WinServiceContainer:main with status=3
[2019-03-29 18:09:38] [error] ( prunsrv.c:1183) [10664] Failed to start Java
[2019-03-29 18:09:38] [error] ( prunsrv.c:1536) [10664] ServiceStart returned 4
[2019-03-29 18:09:38] [debug] ( prunsrv.c:844 ) [10664] reportServiceStatusE: 1, 1066, 0, 4
[2019-03-29 18:09:38] [info]  ( prunsrv.c:1598) [ 2592] Run service finished.
[2019-03-29 18:09:38] [info]  ( prunsrv.c:1764) [ 2592] Commons Daemon procrun finished

Any suggestion JVM is unable to find WinServiceContainer class and failed to start Java ?

  • Could be a change that some other services running on that port 8081 because I have noticed if Mcafee AV installed then it's uses default 8081 port, you can't install that service on that port, you need to run it in different port – Velmurugan Mar 27 at 18:10
  • What is the database did use for your instance?, In your message, you have mentioned you did try --repository.server=true it's only applicable to HSQLDB – Velmurugan Mar 27 at 18:27
  • 1
    Did you change any of the settings in the installService PowerShell command? Maybe post the settings from that for your 'Not running' services, because those params will be used for starting and running it...also, set the log level to Debug for those services and see if anything more is coming in the logs. – robrtc Mar 27 at 20:36
  • @Velmurugan I tried to run on a different port like 8444, received warnings - 'TCP Connect to localhost:8444 failed' on power shell console. Thus, the same error. Also, database instance I am using is MSSQL. Thus, it is irrelevant. – Bhavesh Malik Mar 28 at 11:47
  • 1
    @BhaveshMalik, No, unless if you are planning to install the staging and live services in the same instance, session content service only applicable to your staging website and Content Service only applicable to your live website – Velmurugan Mar 28 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.