1

We had installed DXA 2.1.0 Resolver in tridion sites 9 but CME is not loading properly. It is working fine after comment out below elements in system.config.

<editor name='DXAResolver'>
      <installpath>C:\Program Files (x86)\SDL Web\web\WebUI\Editors</installpath>
      <configuration>Configuration\DXAResolver.Editor.config</configuration>
      <vdir>DxaResolver</vdir>
    </editor>
<model name='DXAResolver'>
      <installpath>C:\Program Files (x86)\SDL Web\web\WebUI\Editors</installpath>
      <configuration>Configuration\DXAResolver.Model.config</configuration>
      <vdir>DxaResolver</vdir>
</model>

enter image description here

we used below script for execution. .\cms-customresolver.ps1 -extensionTargetFolder "C:\Program Files (x86)\SDL Web\web\WebUI" -cmSiteName "SDL Web"

Please let us know what went wrong.

Thanks in advance.

2

The problem is that you installed the DXA Resolver UI Extension in %TRIDION_HOME%/web/WebUI. This is known to not work properly on Sites 9.

See https://docs.sdl.com/LiveContent/content/en-US/SDL%20DXA-v11/GUID-B2394627-794C-4AF0-BDF3-C5B3A5398327

If you specify another location for extensionTargetFolder (or just use the default location), it should work fine.

  • Thank you @Rick , Please let us know rollback steps. Is it OK if we move Editor(Commands,Configuration,Constants,Resources,Themes,Views and web.config) and Model folder(Client,Configuration,Resources,Services and web.config) of DXA Resolver to other locations and point to new location in system.config. – Sree G Jun 17 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.