2

When setting up DXA 2.2 I accepted the default setting to use the context service. I don't want to go to the trouble of setting up the context service to work properly, so now I'm trying to configure DXA to use ADF instead.

In dxa.properties I have set:

dxa.web.adf.enabled=true

yet still I get exceptions like this:

com.sdl.odata.client.api.exception.ODataClientHttpError: Unable to get response from OData service: No Response. com.sdl.odata.client.util.ODataClientUtils.buildException(ODataClientUtils.java:93) com.sdl.odata.client.caller.BasicEndpointCaller.getResponse(BasicEndpointCaller.java:216) com.sdl.odata.client.caller.BasicEndpointCaller.callEndpoint(BasicEndpointCaller.java:89) com.sdl.odata.client.DefaultODataClient.getODataResponse(DefaultODataClient.java:141) com.sdl.odata.client.DefaultODataClient.getEntity(DefaultODataClient.java:69) com.sdl.context.odata.client.ODataContextEngineProxy.resolve(ODataContextEngineProxy.java:107) com.sdl.context.odata.client.CachingContextEngine.resolve(CachingContextEngine.java:61) com.sdl.context.odata.client.api.ODataContextEngine.resolve(ODataContextEngine.java:46)

Are there other configurations I need to make to be free of the context service? Also - am I correct in wanting to disable it, or is this a problem I could solve in another way.

2

Try enabling these following properties in dxa.properties file

#adf.context.provider - Activates ADF instead of Context Service for context claims.
spring.profiles.active=adf.context.provider
spring.profiles.include=adf.context.provider

ADF is needed for XPM Session Preview, Experience Optimization and Context Expressions. Values: [true, false]:

dxa.web.adf.enabled=true

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.