1

we have done following on our dev environment:

  1. tried to upgrade DXA 1.5 to 1.7 [both application and cms (8.5)]
  2. got messed up
  3. rolled back cm changes by doing DB refresh of Dev cms. we have put UAT cms DB replica into dev cms
  4. rolled back cms changes
  5. topology manager details was not backed up before the DB refresh but cloud team helped us to set it up

post that all required items got published and can browse the website.

though the following error I am getting:

"A problem occurred while rendering this section
Semantic schema '10182' not defined in Localization [19 ('English')]. Check that the Publish Settings page is published and the application cache is up to date."

following is an error from application log:

"2019-10-14 11:54:54,078 [10] ERROR - Semantic schema '10182' not defined in Localization [19 ('English')]. Check that the Publish Settings page is published and the application cache is up to date.
Sdl.Web.Common.DxaException: Semantic schema '10182' not defined in Localization [19 ('English')]. Check that the Publish Settings page is published and the application cache is up to date.
   at Sdl.Web.Common.Configuration.Localization.GetSemanticSchema(String schemaId)
   at Sdl.Web.Tridion.Mapping.DefaultModelBuilder.BuildEntityModel(EntityModel& entityModel, IComponent component, Type baseModelType, Localization localization)
   at Sdl.Web.Tridion.Mapping.DefaultModelBuilder.BuildEntityModel(EntityModel& entityModel, IComponentPresentation cp, Localization localization)
   at Sdl.Web.Tridion.Mapping.ModelBuilderPipeline.CreateEntityModel(IComponentPresentation cp, Localization localization)
   at Sdl.Web.Tridion.Mapping.DefaultModelBuilder.BuildPageModel(PageModel& pageModel, IPage page, IEnumerable`1 includes, Localization localization)"

there are a couple of similar errors also present in an application.

it will be helpful if anybody can provide me any way out.

Note: .net version has not been changed

  • the error tells us that the dxa webapp cannot find a schema with id (pub-id)-10182-8 in the published settings. Can you check that this schema exists in the CM, and that the json files that are published by the 'publish settings' page actually contain this schema ID. It could also be that the dev broker DB contains references to schema id's that do not match the UAT CM db (which you restored). Maybe a full republish might help here – Harald Hoffelinck Oct 14 at 13:50
  • @HaraldHoffelinck: following schema id is not present in dev: (pub-id)-10182-8 after DB refresh. Json file does not have reference of schema id. even i do have similar thought that may be dev has those schemas and post uat db restored in dev, that reference is some how broken. i liked your idea to check broker db for that schema id. at least this will help to understand how application is expectation that shema id. – soumava sarkar Oct 15 at 5:45
  • could you set logging to debug? That would allow you to get more info on when this error occurs (with which component). This would allow you to track down what schema this is. Next, you could then try and republish all components using that schema. – Harald Hoffelinck Oct 15 at 7:04
  • since you mentioned you did only CMS DB refresh, not broker DB refresh from UAT to DEV, if not I would recommend, either start with empty broker database and start to republish all the items from your CM or also Do the UAT broker db to DEV broker db refresh and then refresh, delete the BinaryData folder in your web app and then try again. – Velmurugan Oct 15 at 7:11
  • @HaraldHoffelinck: application log level is already set to debug. and error is coming from header page. component presentation created for adding canonical urls. – soumava sarkar Oct 15 at 7:49
0

as suggested by Velmurugan. issue was with broker DB as that has not be restored at the time of CM db restore from UAT.

today we have restored UAT DB to Dev and problem has been resolved.

Thank you all for your help and suggestions.

  • Glad that you've figured it out. Please accept your answer so the question becomes closed. – Atila Sos Nov 17 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.