2

Not able to access the DD4T website, noticed the following warning in Application Event Viewer. Will this warning makes the website not to function ?

Could not load file or assembly 'Tridion.ContentDelivery, Version=8.5.0.1014, >Culture=neutral, PublicKeyToken=ddfc895746e5ee6b' or one of its dependencies. >The located assembly's manifest definition does not match the assembly reference.

Bin folder contains Tridion.ContentDelivery dll with version 8.5.0.1013. So, made changes in the web.config as below

<dependentAssembly>
       <assemblyIdentity name="Tridion.ContentDelivery" publicKeyToken="ddfc895746e5ee6b" culture="neutral" />
       <bindingRedirect oldVersion="0.0.0.0-8.5.0.1013" newVersion="8.5.0.1013" />
  </dependentAssembly>

Expected to resolve the issue and website should function. But I still see above mentioned warning and website fails to load with run time exception. Will this warning cause the website not to function and how to resolve this warning?

1

Welcome to Tridion stack exchange, Error message Indeed!, When you get this kind of errors, it's due to that the DD4T version you are trying to install or use is built against a different version of the Tridion.ContentDelivery DLL.

You need to ensure that your DD4T solution rebuild with the right Tridion DLLs version since you updated your web.config to load .NET to use the specific Tridion.ContentDelivery version of the assembly, but your application somewhere did uses or has a reference to Tridion.ContentDelivery, Version=8.5.0.1014, you need to find and fix or you can remove the Tridion.ContentDelivery from your project reference and try to reference to your Tridion.ContentDelivery DLL to rebuild.

I hope it helps.

  • Thanks @Velmurugan for your response. I will try the options that you have mentioned.But where can I find this exact 8.5.0.1013 version of Tridion.ContentDelivery dll? – nag Oct 20 at 17:06
1

Are you using the NuGet reference to DD4T.Providers.SDLWeb8.5.CIL? If you do that, the correct Tridion DLLs will always be loaded automatically.

  • Thanks Quirjin for your response..Yes, I am using nuget references. Sometimes it is referencing to a different version. – nag Oct 24 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.