0

enter image description here

I’m learning and trying to setup DXA 2.1 example site on Site 9 environment.

I tried to follow the steps mentioned in the document (we have publishing working for other publications already) When I try to publish any page of example DXA site, nothing happens. Attached screens

Please help with setting up topology mgr.

enter image description here

4
  • For me seems like Mapping from Web application to Publication may be missing, Can you run this "Get-TtmMapping" PowerShell cmd on the CM server and update the question.
    – Velmurugan
    Oct 27, 2019 at 18:21
  • @Velmurugan Updated question with image
    – Sikarwar
    Oct 28, 2019 at 3:36
  • Can you double-check that example publication Id has a mapping?
    – Velmurugan
    Oct 28, 2019 at 19:10
  • @Velmurugan No, I dont see the example publication mapping.
    – Sikarwar
    Oct 28, 2019 at 19:44

1 Answer 1

1

Indeed, The mapping is missing.

Create the Mappings and then publish and test, it should work:

Add-TtmMapping -ID Mapping1 -CmEnvironmentId Tridioncm_localhost -PublicationID tcm:0-5-1 -WebApplicationId Website1_RootWebApp -RelativeUrl /

Note: CmEnvironmentId, PublicationId, and WebApplicationId should be your environment-specific values

For PublicationId - Note down your example website publication Id.

For CmEnvironmentId - run this Powershell cmd Get-TtmCmEnvironment and note down the Id.

For WebApplicationId - first, run this Powershell cmd Get-TtmWebsite identify the base URL and cd environment and note down the Id, and then run the Get-TtmWebApplication -WebsiteId Website1, note down the Id, once you know all the parameters values of the Add-TtmMapping then proceed to create the mapping and publish and test.

The example website configuration should look like this for your reference, but the values and Ids are differs based on customer-specific values.

PS C:\Users\vagrant> Get-TtmCmEnvironment

CoreServiceRootUrl     : net.tcp://localhost:2660
WebsiteRootUrl         : http://localhost:80
CoreServiceCredentials : "AuthenticationType":"Windows", "UserName":"VAGRANT-2016\MTSUser", "Password":"********"
Id                     : Tridioncm_localhost
ExtensionProperties    : {}


PS C:\Users\vagrant> Get-TtmWebsite

BaseUrls             : {http://localhost:8852}
CdEnvironmentId      : CdEnvironment1
EnvironmentPurpose   : Staging
CdEnvironment        : 
ScopedRepositoryKeys : {DxaSiteType, DxaExampleSite}
Id                   : Website1
ExtensionProperties  : {}

PS C:\Users\vagrant> Get-TtmWebApplication

ContextUrl           : /
WebsiteId            : Website1
EnvironmentPurpose   : Staging
CdEnvironment        : 
ScopedRepositoryKeys : {DxaSiteType, DxaExampleSite}
Id                   : Website1_RootWebApp
ExtensionProperties  : {}

PS C:\Users\vagrant> Get-TtmMapping

CmEnvironmentId     : Tridioncm_localhost
PublicationId       : tcm:0-5-1
EnvironmentPurpose  : Staging
WebApplicationId    : Website1_RootWebApp
RelativeUrl         : /
PrimaryMappedUrl    : http://localhost:8852/
IsOffline           : False
CdEnvironment       : 
Id                  : Mapping1
ExtensionProperties : {}

I hope it helps.

5
  • thanks a lot. This resolved the issue.
    – Sikarwar
    Nov 2, 2019 at 2:23
  • I am able to publish the pages in tridion. Now as per the documentation, I ran below command, and after that tried to run the application. But getting error that "No matching Localization found for URL 'localhost:8888'". In this application I dont see configuration files where we need to define the publication Id and all. Examaple .web-install.ps1 -distDestination "C:\inetpub\wwwroot\DXA_Staging" -webName "DXA Staging" -sitePort 8888 -discoveryServiceUrl localhost:8082/discovery.svc
    – Sikarwar
    Nov 2, 2019 at 4:04
  • Please let me know
    – Sikarwar
    Nov 2, 2019 at 18:34
  • I'm getting this error, please help. ERROR - Sdl.Web.Delivery.Service.InvalidServiceEndpoint: Unable to retrieve context engine service uri from discovery service. No ContextServiceCapability found!
    – Sikarwar
    Nov 2, 2019 at 19:07
  • Good to know you resolved the issue, please accept the answer and raise a separate question for other issues
    – Velmurugan
    Nov 2, 2019 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.