0

We have a bad performance in DXA Model Service and we think that is related to the Depth level configuration. We changed it in the CME, in the Admin tab -> DXA Settings and republished "publish settings" page. But that we see in Model service logs is:

2019-10-28 08:32:01,450 WARN  c.s.d.m.s.p.e.PageModelExpander - Cannot expand entity EntityModelData(id=80784-302829, componentTemplate=null, linkUrl=null, content=null, binaryContent=null, externalContent=null) for page PageRequestDto(publicationId=41, uriType=tcm, path=/nh-web/en/index2.html, includePages=INCLUDE, contentType=MODEL, dataModelType=R2, expansionDepth=100, depthCounter=com.sdl.dxa.common.dto.DepthCounter@98)

How we can configure this field? Where is stored? How it works?

Thanks!

  • Similar to this issue, tridion.stackexchange.com/questions/19700/…, check-in the broker database is there any DCP component output published as an empty string instead of Json ouput, republish that DCP it will result the issue. – Velmurugan Oct 28 at 13:42
  • Thanks. I'll check it. But expansionDepth is configurable? – Guskermitt Oct 28 at 15:19
  • 1
    Yes. What you have done DXA Settings it's correct, It's stored in following Render Component Content and Render Page Content TTBs TemplateParameters to keep the value, In case if you looking to change that value then you can duplicate that template and the parameter specific to PTs and CTs as required, if not it will apply same value for all your PTs and CTs – Velmurugan Oct 28 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.