0

I have Imported DXA Publications into SDL Tridion Sites Content Manager and I am able to publish the pages. After that, I have installed DXA application for .NET, but I am getting below error when I run the application.

Please let me know.

ERROR - Sdl.Web.Delivery.Service.InvalidServiceEndpoint: Unable to retrieve context engine service URI from discovery service.

No ContextServiceCapability found!

1

Indeed. The error message indicating you have not installed and registered Context Service to Discovery Service.

In SDL Tridion Sites 8+ (formerly SDL Web) DXA OOTB uses the Context Service by default and supports server-side responsiveness (e.g. image resizing) the SDL Context Engine to get device data needed for that purpose.

In order to fix the above error, you have to either switch to ADF or enable Context Service.

If you configure DXA to get context claims from ADF, In that case, you will need to configure the Context Cartridge in your Content Service.

In DXA Webapp configure Unity.config in the root of the site DXA web app to change the Unity configuration to use AdfContextClaimsProvider instead of ContextServiceClaimsProvider

 <type type="IContextClaimsProvider" mapTo="AdfContextClaimsProvider">
    <lifetime type="singleton" />
 </type>

I hope it helps.

  • I'm getting a different error now. Server Error in '/' Application. Unable to get Contextual Image Service URL. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: Sdl.Web.Delivery.Core.ConfigurationException: Unable to get Contextual Image Service URL. – Sikarwar Nov 3 at 18:11
  • seems like you enabled ContextualImageProxyModule but Contextual Image Service not enabled, you can disable this in your web.config if you are not using this in modules section, – Velmurugan Nov 3 at 18:58
  • Latest error is this: Sdl.Web.Common.DxaException: 'An error occurred while resolving evidence using the Context Service.' Please help – Sikarwar Nov 3 at 20:21
  • Do one thing to disable the IContextClaimsProvider in Unity.config and then go to Global.asax.cs Application_Start to find and disable this function RegisterDisplayModes(); it will disable context service calls from application completely. – Velmurugan Nov 3 at 20:41
  • thanks for working with me on this. I have commented IContextClaimsProvider type in Unity.config file and commented the RegisterDisplayModes method call in Applicaiton_Start() method of Global.asax. Now I am getting this error: "No implementation type configured for interface IContextClaimsProvider. Check your Unity.config." – Sikarwar Nov 3 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.