1

we setup a new publication for our client. This publication is a child of an old publication but with a different language. when we publish the pages to the preview site, they work fine. but when we publish those pages to live site, all pages displayed as 404 page. what's the problem? we use SDL Web 8.5. The publishing to live site works fine. because we see success status in publish queue. try 'get-ttmmapping' in powershell, it also returns the correct mapping like this:

CmEnvironmentId     : TCMDBUser_OEP6
PublicationId       : tcm:0-461-1
EnvironmentPurpose  : Live
WebApplicationId    : LiveWebsite_RootWebApp
RelativeUrl         : /sea/ma
PrimaryMappedUrl    : https://XXXXXXXX/sea/ma
IsOffline           : False
CdEnvironment       : 
Id                  : Mapping74
ExtensionProperties : {}

DXA 1.6

  • please provide some more details on your front-end web app : is this using DXA, DD4T or some custom development. Also, it would be useful to check any logs you get in your web application – Harald Hoffelinck Jan 20 at 15:29
  • Is that published pages are stored in the database or FS? – Velmurugan Jan 23 at 7:59
  • It could an issue with the way that your topology is being setup. Refer the below link on using context vs relative URL tridion.stackexchange.com/questions/14247/… – Shiva Feb 12 at 18:42
  • can you tell what's the setup issue? those pages sometimes display well, sometimes show 404 error. – Ivy Chen Mar 24 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.