We had a scenario where we had to move contents from 3 or more content publications to a single content publication and all of these publications were on same level of blueprint hierarchy. So We firstly promoted all content and folders from 250 content publication to single parent publication named 200 Shared content publication and that operation happened without any issues. But when we started demoting content from 200 shared to 250 level common content publucation then all components got demoted successfully and even some of folders also got demoted successfully but some of folders are not getting demoted with error i'm getting as below. Please let me know if anybody faced that kind of issue before:

the demoted item cannot be published in publications where it will be demoted from: enter image description here

  • Are any of the folders localised in children? Is the hierarchy exactly the same - that is, does the new publication have any different parents that may have conflicting inheritance/folders? No schemas on the folders? Feb 18 '20 at 8:37
  • HF providedc by SDL helped in providing resolution to this issue Thanks for help Feb 28 '20 at 4:57

Please check following for the items showing error:

  1. are any of those published before promoting to 200 shared publication?
  2. any of the items got localized before promoting to 200 shared publication?
  3. are there any dependent item i.e: linked component etc present?
  4. please query to CM db to understand if any duplicate entry created for same items.
  5. please check if any translation config attached with the items or not.

from the errors my vote will go to point 1 from above list.

If possible please share cm logs incase any detail error description present.

  • Thanks for help. i had checked all dependencies but it was solving the issue but HF came handy (mentioned in answer) at the end. it solved the issue. Feb 28 '20 at 4:56

Thanks all for help. Figured out its an issue with web 8.5 only and SDL provider Hotfix for solution to this issue. i executed this HF and its worked. the HF "CM_8.5.0.6663" will solve the issue and here is link for more information on this issue. https://gateway.sdl.com/apex/communityknowledge?articleName=000005467

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.