2

Please find the information below:

  1. Installed SDL Tridion 9.1 on a Single Machine following docs.sdl.com guide

  2. Installed DXA 2.2 DOTNET

  3. DXA 400 Example site imported and published.

  4. Installed the Add- On Service as per docs.sdl.com installation guide

  5. Uploaded the package "udp-content-dxa-extension-assembly-11.1.0-1061-core" in Add-on service(http://localhost:83/addon/)

  6. udp-content-dxa-model-traformation-extension and udp-content-dxa-graphQL-schema-Extension stuck with the status "Pending Activation"

enter image description here

3

DXD loading mechanism – DXD is loading extensions on service startup. - No support of loading on the fly

After the extensions and configuration have been uploaded to the Add-on Service, the connector/extension is deployed in CM and DXD.

The CM connector will pick up the connector and deploy it on-the-fly, while the DXD service needs to be restarted to get the connector/extensions deployed.

Update:

DXD - Digital Experience Delivery = Content Delivery

Just to clarify to understand.

For your issue you just need to restart your content service after the add-on service configuration and extention upload.

Update2:

Installation of Add on Service in SDL Tridion Sites 9.1

I hope it helps

| improve this answer | |
  • What is this DXD Service and what steps needs to be followed to install this DXD Service. Also it will be a great help if you point me to some document or any path where i can get the step by step approach ... SDL documentation never showing the sequential steps and everything is running in parallel and let to confusion which path to follow – sachin jain Apr 14 at 14:43
  • Updated my answer – Velmurugan Apr 15 at 16:09
  • Hey Rick, I already tried re-starting the session content service. But till now no luck – sachin jain Apr 16 at 6:13
  • then looks like you have some steps or parameter missed in your setup, please refer to blog link for add-on service installation and configuration, updated the answer – Velmurugan Apr 16 at 7:25
  • Than Velmurugan, it works now.. The missing part is the environment variable settings what I feel.... – sachin jain Apr 16 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.